ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Clio’s engine getting loud at a high speed?



  07 MK3 Clio 1.2
Hi everyone.

This is my first post on here so please go easy. I have an 07 MK3 1.2L Clio Xtreme (don’t know what’s extreme about it). It’s on 65k if that makes any difference.

It’s never been a quiet car, however, the past few days we’ve noticed that the engine is starting to hum very loud, louder than usual. The faster we go/higher the gear it gets louder. Yet normally, the car will happily do 95mph but at 50mph and above it’s really loud. And yesterday with the accelerator floored it was struggling at 70mph, but ten minutes later it was back to its normal self.

It was MOT’d in September, had its timing belt and water pump changed at 60K too.
Does anyone have any idea what it could be?
 
  07 MK3 Clio 1.2
Hi everyone.

This is my first post on here so please go easy. I have an 07 MK3 1.2L Clio Xtreme (don’t know what’s extreme about it). It’s on 65k if that makes any difference.

It’s never been a quiet car, however, the past few days we’ve noticed that the engine is starting to hum very loud, louder than usual. The faster we go/higher the gear it gets louder. Yet normally, the car will happily do 95mph but at 50mph and above it’s really loud. And yesterday with the accelerator floored it was struggling at 70mph, but ten minutes later it was back to its normal self.

It was MOT’d in September, had its timing belt and water pump changed at 60K too.
Does anyone have any idea what it could be?
Car has just been juddering at a low speed too.
 


Top