ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Renault Clio 2 Electrical Interior Issue



  Renault Clio 2
Hello everyone,

I have a Renault Clio 2 phase 2 1.5dCI and I had some weird electrical issues.
When I open the electrical window, the rear wiper start running really slowly, and the interior lights get dimmed. Other problem, that I think it was related with the previous, is when the exterior light are on, and the front wipers on too, the dashboard background light and every light in the interior (radio, interior light, chauffage controls light, etc..) blinks. And that blink happens every time that the wiper return to home position and the relay opens.

I already check every fuse on the interior fuse box, I already clean the negative contact on the battery, plus the connection to the car body, and nothing work.

Can anyone experience a similar issue?
 
Last edited:
  Renault Clio 2
Have you checked the condition of the battery?

A failing battery can do strange things!

Thank you for your response!
The problem persist for more than a year, so if it was a failing battery, the battery should be dead by now right?
The car runs every day, so don't had long times without running.
A few days ago, when i tried to find the problem, the car run out of battery. So, I pull the battery off to check and the liquid inside was a little low, sow I fill it up, put on charger and did not failed again since that. I checked the battery voltage, and it seems to be normal... Around the 12V without load, and 14V (more or less) with the car running. The lowest value that I have, was 11V when the car starts, but rapidly backs to normal. Even after all this, the weird electrical problem persist.

Today I will check the battery voltage again.
Once again, thank you for your response.
 

Gus

ClioSport Moderator
  182Turbo,DCi90
Hello everyone,

I have a Renault Clio 2 phase 2 1.5dCI and I had some weird electrical issues.
When I open the electrical window, the rear wiper start running really slowly, and the interior lights get dimmed. Other problem, that I think it was related with the previous, is when the exterior light are on, and the front wipers on too, the dashboard background light and every light in the interior (radio, interior light, chauffage controls light, etc..) blinks. And that blink happens every time that the wiper return to home position and the relay opens.

I already check every fuse on the interior fuse box, I already clean the negative contact on the battery, plus the connection to the car body, and nothing work.

Can anyone experience a similar issue?
Likely to be an earth issue
Off the top of my head you have 2 either side of boot, 3 along dash support bar, 1 in scuttle panel and 4 engine bay earths.
check the condition of them
 


Top