ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Terrible handling after installing front spacers?



  CLio 172
Hey guys, just installed some 20mm front hubcentric spacers from Mtec and the handling of the car has worsened... Car understeers quite a bit and feels noticably unstable?

I'm assuming this is because of the wider track in the front and standard track in the rear? Can anyone shed some light please?
 

RichValver

ClioSport Club Member
  Clio 16v/172 daily
I run 16mm on the front with no spacers on the rear, bit of camber front and back. No issues with handling
 

DomP182

ClioSport Club Member
  ph1 172, Arctic182
Same here with16mm on fronts, possibly 20mm just tips the balance?
 

Louis

ClioSport Club Member
I'm on 20mm front and it handles fine. What are your tyre pressures like? And what are the tyres?

I am on 10mm rear stubs.
 
  CLio 172
Thanks for your replies guys. Tyre pressure was at 33psi a few months ago and are Potenza RE11s with plenty of tread (although a bit old)

Wheels might need a balance?
 

loggyboy

ClioSport Club Member
Wheel balance would only shake the car at certain speeds. Do you have camber adjustment? Check tracking also, it shouldn't be affected by adding spacers, but it may exaggerate any misalignment that was there before..
Also 33 is quite high, Try 26-28 (cold).
 
  CLio 172
Wheel balance would only shake the car at certain speeds. Do you have camber adjustment? Check tracking also, it shouldn't be affected by adding spacers, but it may exaggerate any misalignment that was there before..
Also 33 is quite high, Try 26-28 (cold).
Best to get a wheel allignment then you think? And I will try to lower tyre pressures too thanks
 


Top