ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

182 Cup cuts out when brake pedal touched



  Clio 182 Cup race
Hi all, the car is a 182 Cup racer than has a Gen90 ECU fitted from the previous race series it ran in.

The Gen90 doesn't use the ODB2 port so we have had K-tec re-install a standard ECU. When on the standard ECU the engine runs fine but if the brake pedal is touched the engine cuts out - rev counter drops to zero so seemingly the ignition as a whole cuts out. It will bum re-start.

Re-connecting the Gen90 ECU and the problem goes away. The Gen90 doesn't use all the electrical sources used by the standard ECU.

Any ideas other than checking all parts etc. and looking for obvious connection problems.

TIA
 

MicKPM

ClioSport Trader
  Clio16v/Zoe Z.E.50
Morning.

ideally you need to get a volt meter on to the brake pedal circuit and see what’s happening when you press the pedal.

I suspect you’re pulling down a GND but without knowing the wiring on your specific car, I couldn’t say for sure or where.
 
  Clio 182 Cup race
Morning.

ideally you need to get a volt meter on to the brake pedal circuit and see what’s happening when you press the pedal.

I suspect you’re pulling down a GND but without knowing the wiring on your specific car, I couldn’t say for sure or where.
Ta - yep I think I'll be spending most of the weekend checking connections and wire routing.
 


Top