ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

abs and service lights



  clio campus sport
i have just bought a 2006 clio campus sport. gave it a good run over the weekend and now the abs and serv lights are on. they dont come on straight away but alwayd come on now afeter a few minutes and stay on.
any advice please?
 

MRBILLYUK

ClioSport Club Member
  FF Jeden Osiem Dwa
i have just bought a 2006 clio campus sport. gave it a good run over the weekend and now the abs and serv lights are on. they dont come on straight away but alwayd come on now afeter a few minutes and stay on.
any advice please?
Check the abs rings on the brake discs, they could be really rusty or even split.
It's a common problem on 1*2s so could be the same on your Campus.
 
  clio campus sport
Check the abs rings on the brake discs, they could be really rusty or even split.
It's a common problem on 1*2s so could be the same on your Campus.
I dont know which wheel it is but it failed on a missing or damaged gaitor on the front nearside last year so im assuming its thats one
 

MRBILLYUK

ClioSport Club Member
  FF Jeden Osiem Dwa
I dont know which wheel it is but it failed on a missing or damaged gaitor on the front nearside last year so im assuming its thats one
It could be that side. I'm not saying 100% it is the ABS ring but it's quite common for them to rust or even break bringing up your ABS and service light.
The only way to tell is to take the wheels off and check.
It could even be the ABS sensor or brake pedal switch.
If you search on here you'll find alot of info on the subject.
 
  Clio 172 Ph2
It could be that side. I'm not saying 100% it is the ABS ring but it's quite common for them to rust or even break bringing up your ABS and service light.
The only way to tell is to take the wheels off and check.
It could even be the ABS sensor or brake pedal switch.
If you search on here you'll find alot of info on the subject.


In my 1*2 i had a SERV and ESP warning light that came on every now and again, when it came on it stayed on until the car was switched off and started again.

Turned out to be the brake pedal sensor just above the brake pedal itself under the steering wheel.


Second hand brake sensor replaced from a scrap yard and problem resolved. Cost me about £5 to repair or approx £16 for a new one i think.


Whenever throwing parts at a car personally i always start with the cheapest and easiest to replace.



J
 


Top