ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Bloody heater has just gone...





Hello all,
I went out in my car yesterday to only find that the heater fan has stopped working. It was working absolutely fine, now modes 1 2 3 dont work at all.

I get a small amount of heat coming through when on any of the modes... and if its set to cold - it blows cold air when ure going quite fast!!

However in this weather - cold is not what you need! The fact that my driver and passenger windows have also both given up the ghost means I am pretty buggered (sunroof is my only option at the moment!!!)

Anyone know whats wrong with it?

Ta very moouch

Patrick
 


take the dash apart so you can get behind the heater control panel, check all the cables in the plug at the back of it!

the exact same thing happened to me a while ago in my old RT, one of the wires was burnt brown! gave the connection a clean and worked as good as new!
 


Quote: Originally posted by tomclio1.2 on 15 November 2002


fuse?
Checked that mate!!

I will check all the other points over the weekend... if i dont suceed i think i will let the garage do it!!

Pat
 


Quote: Originally posted by bambam on 18 November 2002

heater matrix??
My heater matrix is full of sh*t so my heatings crap, the blowers however will still fully operate if this is the case. When its cold I can have 1,2,or3 speed cold air! So it wont be the heater matrix in your case.

If you regulary leave clio blowers on for long periods of time apparently they have a tendancy to burn themselves out. I reckon this coz when my heating stopped working thats wot every1 suggested.
 


Cheers nic (and others!).

My mother has offered to be for it to be done at a garage, and to get my leccy windows fixed (both of which no longer work!).

So once it goes in, I will let you know what it was.


Pat
 


Windows could be due to switches - a common problem. Regular switches cost £25 and the one touch ones something ridiculous like £75!!

Heater matrix is another common problem: about £130 to fix.
 


Patrick - Dont get the windows done at a garage! - like ben h said, i bet you itll be the switches. When i bought my car i got some money off coz one of the switches was broke, went to my local scrappy and got a switch for nothing! Really easy to fit aswell.

BenH - You know when you say £130 to fix the heater matrix, is that price for removing all the dash etc and replacing the matrix? I had my matrix rinsed out which has helped a bit but not a lot, is there anything else that can be done?My garage didnt recomend using somthing like rad flush as it might damage the matix and cause it to leak...
 


Im seriously interested because my heater stopped working the other day and I have no idea what it is. Tried testing the fuse and there was no voltage apparently...? Im considering getting an auto electrition but theyre expensive. Once you find out what happened can you please let me know. Mines a 91 RT... and my heater number 3 stage never worked! lol!

Andi
 


Top