ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Cruise Control/Squib Problem



  Clio 138
Hi ive just bought a clio 2.0 138. The cruise control dont seem to work. The lights come on and the display says cruise control but then 3 lines under so not showing speed and when i press the + - nothing happens. The seller told me he had changed the squib. Ive read theres 2 different ones 1 for cruise 1 for without is this correct or is it just a case of gettings the squib programmed. No idea how to look at the squib bit of a novice to do with electrics.
 

GrahamS

ClioSport Club Member
Seanwinf

The squib is different for models with and without cruise control. It doesn't have a computer so you cannot program it. The easiest way to tell if you have the correct squib is to take off the air bag. Disconnect the battery, on the back of the steering wheel you'll see 2 clips, push them out wards until the airbag unhooks. You will then see if the cruise control buttons are connected. If they are you have the correct squib.

If they are connected you may have a faulty brake or clutch switch which is causing the ecu to not allow cruise control.

Plug into a diagnostic if you have the facility.
 
  Clio 138
grazo22
ive looked behind the steering wheel but theres no plastic clips for me to push? Theres a hole in the back of the steering what looks like some 1 has ripped into or cut a chunk out?
 
  Clio 138
I will get a pic tomorrow didnt think earlier. My horn/airbag cover is slightly proud on the wheel is that the bit i push forward?
 

ForceIndia

ClioSport Club Member
  Gentlemans spec 200
If it's a brake/clutch switch error, the esp/abs warning lights will be on. Try pressing the R (resume) button, this also activates the cruise. Does the speed limiter work? If neither work I'd say it's a squib issue.
 

GrahamS

ClioSport Club Member
Sorry for late reply, kept forgetting!

In the back of this steering wheel you should be able to see where the airbag clips into the steering wheel.

$_12.jpg


This is on my car but it works in the same way. The metal bar bit needs pushing towards the outside of the wheel. I use a screwdriver.

F1B6E00C-8244-42E1-B62A-0D5E5EEAA3AD_zps9le0f0r4.jpg
 
  Clio 138
That fine thanks for helping me. There dont seem to be anything in the hole on the back of my wheel? Bit confusing.
 
  Clio16v/225 Trophy
It looks like someone has done a number on the rear of your wheel where the 1/4" bar inserts. Mk3 wheel airbags are horrible things to get off though so you have my sympathies.
 
  Clio 138
Haha thanks fills me full of confidence. Does it have to be an 1/4" extension bar or can i use something? Why is it i use a 1/4" bar?
 
  Clio16v/225 Trophy
1/4" is the perfect diameter (Around 8mm OD I believe) and it has a flat end which is what you need to force the lower spring clip off the back of the bag unit. The remaining clip makes you feel like you are going to break something.
 
  Clio 138
MicKPM thats great thanks. So i push the bar to the side of that metel bit or push the bar in the hole and that will detach the clip. Sorry not done this before and dont fancy breaking the wifes car!!
 


Top