ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

*HEATER*





:(

How is everyone at Cliosport.net?

Having been training in the RAF its been a long time since I was last here! But here I am, and its your help I need!

My heaters playing up, itll blow out warmish air on setting 1, but any higher and it comes out colder. Bein further up north than Im used to, I am in desperate need of my heater working!

Any ideas?

I would like to know:

1. Does the heater work electrically ie. the radiator is heated by filaments?

2. Or is the heater radiator powered by hot water from the engine?

3. Is it easy/cheap to rectify this problem as I get little-to-no free time to do this myself!

many thanks guys!

Ben
 
  clio 20v


there is a coil behind the dash which the coolant out of the engine is circulated hence when the cars cold the heater doesnt blow warm air,

is the temp guage getting up to temperature, have you checked theres water in the system

the problem probably is cable from the knob that changes between hot an cold has come loose of its mountings and not fully changing to hot

adi
 
  Trophy


Could be your heater matrix is blocked or knackered, flush your cooling system out and pray! 8 hour job to replace at a garage.



Mat.
 


Hey Ben,

Yes I did use the wrap for the manifold, but I wanna get a proper zorst so I can finish it off. Do you want my old manifolds? I can get them to you around xmas time.

Ive flushed the cooling system out but no change, so Im guessing *hoping* its the cable. any ideas what to do next?
 


Top