ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

MK2 172 Trip Computer Failure



  Mk4 MX-5, Smart 451


Has anyone had this seen to yet? Mine is going into Renault tommorow and it would be handy if i knew what the solution is so i can tell them in advance before they start taking half the car apart to find the problem.

Thanks,

Gaz 2130
 
  Clio II 1.4 Priveleg


Trip computer not working.

Please specify not working?

Have you a series of dashes where you would expect to see some results?

Can you run through all the options by pressing the button on the wiper stalk?

I need more info to help you.

BobRTE
 
  Mk4 MX-5, Smart 451


i mean by not working, that when you press the button on the end of the wiper stalk it simply does absoloutely nothing, Renaults response to this the other day was basically its an import and therefore its not going to work (which i believe is a load of sh*t). They did however manage to fix a string of other problems with the 300 mile two day old car without doing any damage.

Gaz 2130
 
  Clio II 1.4 Priveleg


Yep - you are right. It should work even though its an import.

Try this.

Press and hold the button on the end of the wiper switch, then turn on the ignition, the trip computer should go through a self test mode. Release the button and then press it again. You should now see some more figures. Press it again and you should see something else. You may see some letters like DJHT or similar. reset the system by pressing the trip button for the mileage recording in the instrument binacle. This should reset the trip computer. You will need to drive the car at least 0.3 miles for it all to start working again.

Hope that helps - if not post a message and I will try again for you.

Cheers,

Bob
 
  Mk4 MX-5, Smart 451


just tried it Bob and there is still no response whatsoever! Nightmare!! Appreciate your help though.



Gaz 2130
 
  Clio II 1.4 Priveleg


So that didnt work!

That must mean that there is a connection problem from the wiper switch to the trip computer in the dash!

I will look up a wiring diagram and see if I can help you further.

As your car is an import I cannot see a reason why it should not work! and am supprised by your dealers response to your problem. I have had the same fault on other cars (UK spec and imports) where the wiper switch was indeed faulty. Why should you bother to fix it yourself if its under 1st year warranty? But if they wont maybe we can.

The button on the end of the wiper switch only sends an earth signal. So, if we find the right termninal on the wiper switch connector block, we can simply earth this wire to send the right command to the trip computer. If this then activates the computer, the switch is faulty. If not then the problem lies between the connector and the trip computer.

Ill be in touch with a wiring diagram soon
 
  Mk4 MX-5, Smart 451


sorry mate still no joy, Renault dont want to know cos it looks like they havent got a clue what the problem is, and i dont want to go ape about it with them cos they will end up pulling half the car apart and still probably wont fix it, so i dont really know what to do.
 
  Clio II 1.4 Priveleg


Sorry for the delay in getting back with some more help. Have been very busy!

Here goes then. First, remove the steering wheel cowlings, just the upper may suffice. Locate the wiper switch connection plug. There will be 2 rows of wires in this plug. These are labelled A 1 to 7 and B 1 to 7. The letters and numbers are very small and difficult to read (for someone of my age and eyesight!)

The two wires that control the TRIP COMPUTER run through are located in B row, wire 5 (BLACK) and wire 7 (VIOLET) This is only an earth pulse so its quite safe to bridge these 2 wires, making sure you have the right wires in the first place!

With the ignition turned on bridge the two wires, briefly, with a small split pin or similar and see if the trip computer changes display on the dash. If it does, then you have a faulty switch, if not then there is obviously another fault which is beyond diagnosis in a forum! You will have to take it to a Renault dealer.

Hope that helps, let me know who you get on with it.

Regards, Bob RTE
 


My 172 is also an import and the trip computer works perfectley at the moment. I had some warranty work done on mine approx a month ago and Renault took it off me no probs. You have to be carefull with the warranty though. If its an import the warranty starts when it was registered in its pre-imported country.

I bought mine in September but found out through Renault that the warranty started in July!!!

Sounds to me that its the stick thats knackered. Id go down to the dealers and play me face up until they change it!!!
 


Top