ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

problems with different type of front strut fixing on Mk3 RS Sport 2010



  RS4, Dax Rush v8
we are upgrading my sons 2010 mk3 RS Sport for trackdays and have purchased new suspension all round. However before we start tearing the front apart I have been looking at the various videos of what is involved. However all bar one of the videos I can find are for a strut that has two bolts connecting to the hub where as his car has only one. The strut appears to lift out rather than pull out the front which the two bolts type appear to do. However the only video I have seen showing the same type the chap gives up as he couldn't get enough movement to lift the strut clear of the hub mounting and ended up using a garage.
What exactly is necessary to replace this type of strut. Can you drop the hub further or is there a cunning trick to do this?
 

Martin_172

ClioSport Club Member
undo top mount, undo lower damper bolt, undo drop link, knock hub down to release shock, remove shock.

get some penetrating fluid and soak it the night before if your worried about releasing the shock from the hub but I've never had any issues with them tbh
 
  RS4, Dax Rush v8
Thanks, it seems straightforward then. I already given them a good dose of penetrating fluid so hopefully my concern about being able to drop hub enough is unfounded.
Cheers
 
  RS4, Dax Rush v8
I have just spent an age trying to get just one of the old suspension units out from the hub carrier. Whilst I agree we had to remove the three items Martin_72 listed we did find this did not give us sufficient drop to remove the old units. We ended up removing the lower arm ball joint clamp bolt, track rod end bolt and I think its called the side stiffener bolt. This then allowed the hub carrier to be dropped enough to remove the old suspension unit.
Putting the new units in was ok except that, and I think his may be the camber adjustment but not sure (guidance appreciated), the Yellow Speed unit does not sit square in the socket of the hub carrier although there it is in far enough to fit the single bottom bolt. I am not sure this is acceptable and will tomorrow adjust the camber and see if this allows the strut to move back at the top sufficient for the base to sit squarely in the hub carrier.

I believe we may have got away with only removing the track rod end bolt and / or the stiffener bolt but no doubt will find out tomorrow when we tackle the other side.

Any guidance would be greatly appreciated.

Cheers
 
  RS4, Dax Rush v8
A bit of an update to fitting Yellow Speed coilovers to clio3 RS Sport 200. The top surface of the hub carrier is not parallel to the base and so the lip on the coilovers will not sit square to the top of the hub carrier. The camber adjustment will either have to be carried out prior to fitting the strut into the car or you will have to open the aperture on the shock tower to allow access to the Allen key headed locating bolts; this will be quite a large aperture you end up with. Whatever happens you will need to open up the existing tower hole to accommodate the strut bolt and damper control if you move the camber to anything other than central position.

I hope this helps anyone having a problem.
 


Top