ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Snapped Earth on to Strut Mount



chiswickcollectables

ClioSport Club Member
  Clio 182
Hi all, our 182 wouldn't fire up the other day, quickly figured out why (see pic).

Hoping someone can help me ID this part and/or part number so I can replace. Out of interest does anyone know why it's even there? Presumably something to do with the immobilizer.

I've searched for previous threads but couldn't find anything.

The bodge in second pic isn't reliable so any help would be appreciated.

Cheers,
Craig
 

Attachments

  • 1.jpg
    1.jpg
    586.2 KB · Views: 26
  • 2.jpg
    2.jpg
    672 KB · Views: 25

DavidDave

ClioSport Club Member
That’s just the ECU cover, it’s super common for them to break @CFAB makes a repair piece. However I very much doubt it has anything to do with your car no starting unless something is rattling loose in the ECU. Most clios have snapped tabs there
 

Porl

ClioSport Club Member
Getting the ecu cover off is a real pain. I'd be looking at other more common possible reasons for it not starting before messing with that.
 

Porl

ClioSport Club Member
I’m glad you said that! I can’t move mine for trying…I have sourced a new ecu cover now from @frayz so will angle grind the s**t out of my current one if needs be
They are a nightmare. The cover is hardcore af and the ecu mount is like bible paper it's suck a s**t thing to have to wrestle with.
IMG_20210510_143902.jpg

I didn't have a good time with it 😂.
 


Top