ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

182 miltek exhaust blowing



RBfroggy

ClioSport Club Member
  Clio sport 182 RB FF
Hi there, Has anyone else got a miltek exhaust on there 182 having problem's with the welds blowing.
When I brought the car couple of months ago it was fine but now just seems loud and I can see gases coming from weld on pipe coming from decat.
Also had to re-weld the support bar that connects the two backboxes.
Just think for a big name in exhausts don't seem very good to me.
Also on acceleration sometimes on cold start the exhaust will pop and acceleration is really sluggish. Can anyone help. Thanks
 

Brigsy

ClioSport Club Member
  Kangoo 172cup
Sluggish/hesitation from cold is absolutely normal, they all do it unless its mapped out.
 

RBfroggy

ClioSport Club Member
  Clio sport 182 RB FF
Suppose with you saying that and the exhaust blowing aswell makes sense, I bet the decat would have a factor aswell wouldn't it ? I was just worried cus I've had 3 clio sports and this was the 1st one that does it, but they were both standard cat back exhausts and solid.
 

Louis

ClioSport Club Member
Mine does exactly the same from time to time in terms of the popping/banging and feeling sluggish. If you let the car warm up a bit more it's usually better.
I run the same non res decat milltek system and removed the flange and had a vband fitted instead as this helped to reduce the blow in the system. Cracks on the milltek is also common, i had welds to the backboxes completed at the same time but its been fine since!
 

RBfroggy

ClioSport Club Member
  Clio sport 182 RB FF
Think I'm gna go ktec again or try pure motorsport, seen their system on YouTube, sound's really nice😁
 

RBfroggy

ClioSport Club Member
  Clio sport 182 RB FF
Yh that's what I had on my 1st 182 loved it, hard to find now tho 😔
 

Brigsy

ClioSport Club Member
  Kangoo 172cup
Mine used to be annoying in cold weather/cold start, hesitating until the engine and warmed up slightly, took a mile or so of driving. Never noticed it in summer, by the time id fired it up and opened the drive gates, the engine was warm enough. Mine was decat on stock ecu, always meant to get it mapped out.

Its renault’s effort on cold start map to warm up the cat fast. The Megane 225/r26 is the same, hesitates from cold. Efi mapped the cold start on our megane to get rid of this and it drives great from cold now.
 

RBfroggy

ClioSport Club Member
  Clio sport 182 RB FF
Mine used to be annoying in cold weather/cold start, hesitating until the engine and warmed up slightly, took a mile or so of driving. Never noticed it in summer, by the time id fired it up and opened the drive gates, the engine was warm enough. Mine was decat on stock ecu, always meant to get it mapped out.

Its renault’s effort on cold start map to warm up the cat fast. The Megane 225/r26 is the same, hesitates from cold. Efi mapped the cold start on our megane to get rid of this and it drives great from cold now.
 

RBfroggy

ClioSport Club Member
  Clio sport 182 RB FF
Exactly the same as mine then, Just happy to know it's normal 😊 Does a remap on standard 182 engine make a noticeable difference?
 


Top