ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Airbag + SERV lights - Fault code DF0074



  02 Iceberg 172
In the last week I have been getting intermittent, tending to in the last day or so more permanent AIRBAG + SERV lights on the dash - though when I start the car no lights show for a few seconds before they come on again. I had hoped it was the common pretensioner connector issue under the seats but fiddling with them did not sort it, and after getting RSTuner on it this morning it is showing fault code DF0074 - which indicates it's an issue with the passenger airbag in the dash?

20200717_084654.thumb.jpg.12db1dbc9ddb1226a5ef7b76ba12d6b0.jpg


Searching on here for DF0074 doesn't bring up anything, though DF074 does - which seems to be either 'passenger front airbag circuit 2, open circuit' (which sounds the same as my issue) or 'Steering Wheel angle coherence' (which isn't my issue).

I will be removing the dash top on the weekend to have a look, but just wondering if anyone on here has experienced this fault before - did it require the passenger airbag to be replaced or could it possibly be just a loose connector issue? Seems unlikely to be a loose connector but I guess you never know...

Cheers
 

SiC

ClioSport Club Member
Live sensor view the airbag controller and then wiggle the connector to see if it goes from Zero Ohms to something like 3.3Ohms. Very, very rare that the airbags themselves go open circuit (unless they have been activated!) - almost always the wiring.
 
  02 Iceberg 172
Thanks for the advice - I didn't get a chance to check it out on the weekend but will do this coming one (y)
 
  02 Iceberg 172
Problem resolved 👍

Had the dash off yesterday and took a look, but cleaning and re-seating the connectors etc didn't magically clear the fault. From what I could see the airbag ECU was also clean and I hadn't ever spilled any drinks on it, nor did it look like previous owners had either.

Thankfully I was able to source a replacement airbag from a local Clio 2 owner and picked it up this morning, swapped it over this afternoon and voila! Lights off on the dash straight away, and I was then able to clear the fault via RSTuner. So all good again
default_icon_smile.gif


On another note, how bad is some of that light density foam in places under the dash? If you even as much as touch it it turns into this sticky black mess like tar, especially around the openings where the end dash vents connect to the under dash ducting 🤮 Ended up removing it from there, cleaned it up and replaced with fresh foam strip - unlikely to make any noticeable difference but I felt better about getting rid of it...
 


Top