ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

high revs on tick over



  172 16v
got in my car this morning started it up and its ticking over at 2000 revs, the dephaser is in need of a new 1 and has been for a few months could this be the reason why its all of a sudden reving high , is it the dephaser getting worse?? please help
 
  172 16v
its droped back down to where it should be now but wen i rev the car to the limiter it sounds like its splutterin abit and the little green light on the dash on the right at the bottom flickers in does any1 no wat that light is ???
 

DrR

ClioSport Club Member
  VW Golf GTD
The light thats shapped like a gearstick?

Are you revving it to the limiter when not driving?
 

DrR

ClioSport Club Member
  VW Golf GTD
It's the "you should have really changed gear by now light"
Also poor car :(
 

DrR

ClioSport Club Member
  VW Golf GTD
Guessing not, but you've probably broke it fro revving the nuts of it lol?
 
im not an expert - but would the revs be higher on tick over if your battery was low on juice? and trying to recharge itself??

or does it only do that whilst moving..
 
  172 Cup (Iceberg)
Hmm.... mine has an high tick over. Would be good to know what is causing it. It's a bit like the choke is stuck on or something. But it will be fine after 10 minutes or so driving.

Would be good to know what it is.
 
  172 Cup (Iceberg)
Throttle body cleaned today . . still ticking over at over 2000 rpm. Hmmm . . . .
 
  TTRS & V50
Does it tick over normally once hot ?

Mine does this when you turn it over from cold, it holds the revs at 1.5k ish but 2 mins later they die down to idle normally.
 
  172 Cup (Iceberg)
It calms down yeah. It's longer than two minutes though . . . I'd say about 20 minutes of driving then it goes back to normal.
 
  172 Cup (Iceberg)
Well maybe I was a little hasty on my assesment after cleaning the throttle body but after a few days of driving it has now settled down to what I would consider normal.

Result.
 
Bumping an old thread here, but mine is doing a similar thing.

Is it likely to be this same issue when it gets wet or might it be the battery? I was washing it tonight and dropped a bucket of fooking water all over the shop. Fool!
 
  renualt clio 1.2 rn
Mines is doing this too after I just bump started it, cos my starter motor went.. my throttle body is caked when i checked to see if it was jammed, so think I will clean this first....then hope when fitting new starter it will just goes away :D
 


Top