ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Poor braking in the wet





My brakes have felt noticably unresponsive in the terrential rain weve had lately. I wouldnt describe them as spongy - they feel just as firm under your foot.. they just dont brake as agressively as normal.

Any ideas? Anyone else noticed the same?
 
  Renault Laguna Coupe


Thats one pf the drawbacks of having discs all-round. Lesser cars which have drums at the back brake better in the soaking wet British winter. After 50 yds in the rain the discs are wet through and wont bite nearly so well.

Cant have your cake & eat it I spose.
 


Is that it Mike? I hadnt heard of it before.. and my previous cars had drums at the rear. I just thought it couldnt be as simple as that! :oops:
 


Matt,

you could try some groved discs? these will clear the water better than standard discs but it could also be down to the combination of pads/discs that cause the problems (dont suffer as ive got a 2 piece groved disc set on me car ;))



Tony
 


Thanks Tony. Will keep an eye on it.

And no Captain... everything is bog standard.

I have to say that the difference is quite noticeable. Im sure theyll stop me just as well.. they probably just need a harder push. It means you have to re-calibrate your left foot. Worth remembering if you are used to braking later than the average bear!

If this is normal it seems a bit odd/unsafe to me.
 


I must admit I have not noticed this at all, the car seems fine - as do the brakes, mind you I automatically adjust my driving style to suit conditions so may be compensating for it.



Joe.
 


I change my style in that I expect less grip between the tyres and the road in the wet.. I didnt expect less performance from my brakes.
 


I remember replying to someone elses post about this over a year ago - I tried finding it but it appears to be somewhere in the big 1274 page long thread that weve got titled "BenR question for ya?" (A bug methinks! :sick:)

A lot of people suffered from it, but it only seemed to be a problem at higher speeds (ie Motorways) where you go for a while before using the brakes. As adi mentioned, if you use the brakes (even briefly) then re-apply them they seem to bite much better the next time...

Ive had the chimps take a look at it, and they couldnt find anything wrong (unsurprisingly) and claimed no knowledge of similar problems.

Matt
 


Thanks very much Matt.. thats exactly as Id describe it. Also agree with Adi that a few squeezes and theyre ok again. Very odd... and quite scarey the first time it happens.

Guess Ill just have to allow for it.
 


Top