ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Strange things with dash



Don

ClioSport Club Member
  182 & LY Clio 220 ed
So...car has been sat in garage and barely used. Got to her today and she started fine, dash lights showed, but the fuel gauge and rev counter didn't move at all when the engine was running. Also, the mileage part of the dash wasn't showing.

Haven't taken the dash top off as of yet, but wondering if anyone has seen that before.

Car is a 2004 182.

Thanks in advance
 

Louis

ClioSport Club Member
So...car has been sat in garage and barely used. Got to her today and she started fine, dash lights showed, but the fuel gauge and rev counter didn't move at all when the engine was running. Also, the mileage part of the dash wasn't showing.

Haven't taken the dash top off as of yet, but wondering if anyone has seen that before.

Car is a 2004 182.

Thanks in advance
Likely battery related due to lack of use.
 

Don

ClioSport Club Member
  182 & LY Clio 220 ed
Likely battery related due to lack of use.
I would hope not as battery was showing just over 12v at standstill and 14.4v when running. I have a spare I can swap out, so will give that a go when I'm next over there. Cheers
 

MRBILLYUK

ClioSport Club Member
  FF Jeden Osiem Dwa
I would hope not as battery was showing just over 12v at standstill and 14.4v when running. I have a spare I can swap out, so will give that a go when I'm next over there. Cheers
12v is a bit low. Should really be around 12.6v if the batteries in good condition. See how you get on when you swap the battery.
 
  • Like
Reactions: Don

Don

ClioSport Club Member
  182 & LY Clio 220 ed
How long are you leaving it sat for without using it?
It's my play car, sits for weeks at a time.doing nothing. I don't do much with her to be fair. It's a 50 mile round trip to the garage, so it's not my daily. About 2k miles per year, if that...
 

Don

ClioSport Club Member
  182 & LY Clio 220 ed
Thought about getting a trickle charger?
The garage is nowhere near a power supply. It's a garage for storage, near other garages, so doesn't have any form of power, hence why I've not used one before. Get where you're coming from, but it isn't feasible where the car is stored.
 

MRBILLYUK

ClioSport Club Member
  FF Jeden Osiem Dwa
Make sure the battery you're going to swap is fully charged. Then I'd give the car a good drive and see if that clears up the problem. At least that way you'll know if it's battery related or not.
I dry stored mine a couple of years ago for 7 months without starting it periodically , the battery was quite new and it didn't like it. Once the battery was fully charged and back up and running it was fine.
 
  • Like
Reactions: Don

Don

ClioSport Club Member
  182 & LY Clio 220 ed
I've a fully charged Yuasa one I charged up the other week, so I might go back in a bit and swap it over to see if it has the desired effect.

Appreciate the help and advice from everyone so far.
 

Don

ClioSport Club Member
  182 & LY Clio 220 ed
Battery changed for a fully charged one and still nothing. So dash top off and check connections, etc or hunt for a new set of clocks with 111k on there.


Looking like some form of connectivity with the dash clocks. No clocks move at all....the backlight has gone so when the headlights are activated, the lights come on (headlights), but the dash back light leds don't come on.
 

Attachments

  • 20211114_133016.mp4
    15.9 MB · Views: 0
Last edited:


Top