ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

VPN help required



I have never set up any kind of VPN, I've only ever done remote desktop (from home to work).

There are 5 PCs in the office, 1 of these act as a server running XP (shared files / backup drives / SAGE and ACT datafiles). The router is a BT 2700.

I'd like to be able to map a drive on my home PC (Windows7), and the MD's home PC (Windows Vista), to access the 'server' files, and be able to use SAGE and ACT from home without remote desktop.

I've no idea what I'm doing, any guides or assistance is appreciated :eek:
 
Ok, so on the XP 'server' machine I've done the above. I've allowed VPN, and I've set up a PPTP 1723 to point to the 'sever' IP address.

I can't find any passthrough settings.

How do I test / connect to the router / machine?

The router has a static IP, am I connecting to that?
 
  182
Connect to the routers external IP yes. Create a dial up connection on the home computer and chose VPN then enter the IP address of the router at work.
 

welshname

ClioSport Club Member
make sure you set it to use your own internet connection. you arent dialling up to one via a modem :)

obv once connected you use your username and password and then to find the drive just stick

\\xxx.xxx.xxx.xxx(this should be your INTERNAL IP) and then you can see the shared folders, just map from there.
 
Thanks, I'll try this later from home, I've got the router static IP to use.

The username and password it's asking for, is this the 'user' I created on the VPN, or the router's user/password?
 

welshname

ClioSport Club Member
depends on the router. im assuming it is the router you are using for the VPN rather than the "server"

never tried it with a "server" running xp but it only takes a second to create a VPN on XP so try both.
 
  182FF with cup packs
Thanks, I'll try this later from home, I've got the router static IP to use.

The username and password it's asking for, is this the 'user' I created on the VPN, or the router's user/password?

The server.

All your router is doing is passing the packets from it to the server.

If it doesn't work, it's because it's not sending the GRE through. Have a read of this http://business.forums.bt.com/t5/Broadband-and-internet/PPTP-Passthrough/td-p/7759 and see if you can forward IP protocol 47.
 
Doesn't seem to be working.

PC1 @ work = VPN created, set to allow incoming settings, username & password created
PC2 @ home = VPN connection created, pointing to router static IP, using created username & password
Router @ work = PPTP set to 1723, forwarding to PC1

If I type the username & password incorrectly, it flags up as incorrect (so it must be connecting to the machine) but when I type it correctly, it says;

"Error 720: A connection to the remote computer could not be established. You might need to change the network settings for this connection."

Those settings in the PPTP passthrough on the BT website is what I've done, there's only one option on there (Adding PPTP to the chosen PC)
 

sn00p

ClioSport Club Member
  A blue one.
As above, make sure that the router server side is forwarding everything to the server pc that it needs to, PPTP/IPSEC can be a b*****d because it (as pinko points out) GRE uses it's own protocol, depending on your router you may or may not be able to make it work.

Also remember that your network and the work network need to be on different network ranges, otherwise it doesn't work.

Edit: Seems your router does support it.

I just released (I'm tired) that you're talking about PPTP....I haven't set one of those up. I set up our work VPN to use L2TP/IPSEC.

Was pretty easy to test from the office, I just kept trying to connect with my iPhone via 3G until it worked.

If you're still having trouble I suspect it's time to break out the packet sniffer on the server and see what is going on.
 
Thanks guys.

I've finally managed to connect to the network, and access the one machine.

Still restricted from accessing other machines within the office, but will spend more time tomorrow.
 
  182FF with cup packs
Thanks guys.

I've finally managed to connect to the network, and access the one machine.

Still restricted from accessing other machines within the office, but will spend more time tomorrow.

Don't hold me to this, but that's probably because XP disables routing by default. So you can't route through it. IIRC there's a registry setting somewhere. I remember having to change it when I used a laptop was a wireless/ethernet bridge to steal WiFi :)
 
My head hurts.

I got this working today, 100%.

But while this was working, 2 PCs on the network (wireless) lost connectivity. Since 10am, these machines have had no internet or network access, it's as if the network isn't allowing them on :(

My iPhone, iPad and laptop connect to the network fine (wired and wireless), but these two machines fail. I can't understand what has caused this.

Any ideas? I assume something I've changed has had this impact, as these machines are not involved in this VPN. I've changed so many settings I can't remember what to change back (IP, gateway, dns, pptp)
 

welshname

ClioSport Club Member
My head hurts.

I got this working today, 100%.

But while this was working, 2 PCs on the network (wireless) lost connectivity. Since 10am, these machines have had no internet or network access, it's as if the network isn't allowing them on :(

My iPhone, iPad and laptop connect to the network fine (wired and wireless), but these two machines fail. I can't understand what has caused this.

Any ideas? I assume something I've changed has had this impact, as these machines are not involved in this VPN. I've changed so many settings I can't remember what to change back (IP, gateway, dns, pptp)

check the network adapter settings on each machine and make sure that they are set to obtain IP automatically and to obtain DNS automatically.

if they are already that give them a static internal ip and put your router as default gateway, then put your dns server details in. you dont ened an alternate.
 
Ok, on the router I've set PC5 to IP 192.168.1.10.

On PC5 I've changed the Internet protocol settings to:

IP address: 192.168.1.10
Subnet mask: 255.255.255.0
Default gateway: 192.168.1.254 (same as router IP)

With the above settings, it then won't allow DNS set as auto, how do I get this info?

PS5 just sits there, 'trying to connect' after inputing the username & password.

As I say, my laptop on my desk is set to obtain IP automatically, and it connects using the same user/pass.

PC5 = XP
My laptop = W7
 
use dns as 192.168.1.10

;)

Thanks.

I'm at the office again today trying to sort this :(

PS5 now has;

IP address: 192.168.1.10
Subnet mask: 255.255.255.0
Default gateway: 192.168.1.254 (same as router IP)
DNS: 192.168.1.10

The router is showing PC5 as an allocated fixed IP of 192.168.1.10 (not connected)

The router settings are:

Configure manually
Router address; 192.168.1.254
Subnet mask; 255.255.255.0
First DHCP; 192.168.1.1
Last DHCP; 192.168.1.253

Network Name (SSID): xxxxxxxxx
SSID Broadcast: Enabled
Wireless Channel: 6 (2437 MHz)
Wireless Mode: 802.11b/g
Maximum Connection Rate: 54Mbps
Authentication Type: WPA-PSK and WPA2-PSK
Use custom encryption key: xxxxxxxxxxxxx
Wireless Power Level: 1

The XP machines (wireless) won't connect, yet the iPhone/Windows7 laptop will.

The little hair I have left, will be gone by today :(

(beer tokens for a fix :eek: )
 
Cant you just set the router at home + router at the office to have a vpn tunnel?

That way you dont need to piss about with any settings on the actual machines. Just fire in the \\ip address\share name?

This is how we run about 45 of our remote locations at work and we rarely have any problems!
 
The problem has moved on from the VPN original issue now.

It's simply the XP wireless machines in the office will no longer connect to the router/network, since I sorted the VPN.

These XP machines haven't been touched, but will no longer connect, even though the Windows7 laptop, and iPhone connects fine :S

I've removed all traces of the VPN (as far as I can see) from the server/router settings, yet something must be stopping them connecting.
 
Ok, think I've fixed it.

Changed the WPA2 option to WPA, and seems to allow the XP machines back on. :S
 


Top