ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Clio mk3 clicking front drivers side?



  Clio 1.2
I’ve had a clicking sound on the front drivers side of my car for a few months and I can’t figure out what it is.
it started happening a few thousand miles after changing dics and pads.
It happens when pulling off or when I accelerate then come off the accelerator.
What I’ve changed:
Brake pads (Again)
Brake pad guide shims
Drop link
 
  Clio 1.2
Does it get worse when cornering tightly in one direction?

Could be a dry CV joint on a driveshaft.
No it happens when going straight and turning but it doesn’t sound like a cv joint and I’ve checked it and it’s greased and the boot is good.
 
If you can get it onto axle stands or a lift at a garage, you could spin the wheels by hand and see if anything's making a noise, and then check out the bearings / driveshafts / etc.

I think you could probably even start it up and stick it in gear, to check if it makes any noises. (Not guaranteeing that is safe ;) haha)


Does the speed of the clicking change with vehicle speed?

There's nothing hanging down in the wheel arches that might be swinging/rubbing?
 

RSRowe

ClioSport Club Member
  Clio 197
If it’s a Mk3 RS. It needs putting in the air and checking for movement.
Swivel joints make all sorts of noises when they’re dead.
 
  Clio 1.2
If you can get it onto axle stands or a lift at a garage, you could spin the wheels by hand and see if anything's making a noise, and then check out the bearings / driveshafts / etc.

I think you could probably even start it up and stick it in gear, to check if it makes any noises. (Not guaranteeing that is safe ;) haha)


Does the speed of the clicking change with vehicle speed?

There's nothing hanging down in the wheel arches that might be swinging/rubbing?
If I Jack it up the wheel has no movement or doesn’t click when I’m spinning it. I’m going to take the disc off today and clean the hub up to see if that does anything. And no it doesn’t speed up or slow down with speed always makes the same sort of noise. If this doesn’t work today I’ll take it to a garage.
 
If I Jack it up the wheel has no movement or doesn’t click when I’m spinning it. I’m going to take the disc off today and clean the hub up to see if that does anything. And no it doesn’t speed up or slow down with speed always makes the same sort of noise. If this doesn’t work today I’ll take it to a garage.
If the speed of the clicking does not change when the vehicle speed changes, it cannot be something related to the wheel assembly??
 


Top