ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Cruise control buttons wrong functions



rik220

ClioSport Club Member
Evening all,

My 182 has always had a bit of an odd problem with the cruise control. It and the speed limiter work fine but the buttons don’t do what they should.

Currently speed up either cancels or does speed up, depends on what way it’s pressed, speed down always speeds up, the cancel button mostly lowers the set speed. Sometimes it’s a lottery though.

Any ideas on what’s wrong?

Thanks,
Rick
 

Louis

ClioSport Club Member
Evening all,

My 182 has always had a bit of an odd problem with the cruise control. It and the speed limiter work fine but the buttons don’t do what they should.

Currently speed up either cancels or does speed up, depends on what way it’s pressed, speed down always speeds up, the cancel button mostly lowers the set speed. Sometimes it’s a lottery though.

Any ideas on what’s wrong?

Thanks,
Rick
Brake pedal switch.

Is this an aftermarket bracket?
 
  BMW 320d SE
I had this issue with my last 182. The clutch and brake pedals still deactivated the cruise control as per normal. I changed the switch by your right knee. Still no solution. I even checked the resistance of the buttons on the steering wheel, which were all absolutely spot on.


Sent from my iPhone using Tapatalk
 

green

ClioSport Club Member
  Hi comp phase 1
My cruise control would always speed up weather I pressed + or -
I got a good deal on a refurbed steering wheel with buttons and it cured the problem. Must of had a dodgy switch in my original steering wheel.
 

Louis

ClioSport Club Member
What causes the brake pedal switch to cause this??! Sounds very odd
I've no idea, but i've had it before. Maybe creating additional resistance within the circuit? This is linked to the cruise control.
I'm not saying it will definitely fix the issue here, but its worth replacing for £8
 

0ss

ClioSport Club Member
Has the steeing wheel ever been removed? When I swapped mine and fitted a button panel for the cruise I had this issue. Swapping the wires cured it. Iirc there's only 2 wires for the cruise control's, with the same connectors on so its easy to muddle them up.
I had an issue with the brake pedal switch and it just stopped cruise from working at all.
 

rik220

ClioSport Club Member
Has the steeing wheel ever been removed? When I swapped mine and fitted a button panel for the cruise I had this issue. Swapping the wires cured it. Iirc there's only 2 wires for the cruise control's, with the same connectors on so its easy to muddle them up.
I had an issue with the brake pedal switch and it just stopped cruise from working at all.
I replaced the wheel with a non melted wheel. The cruise control was messing about before this but not as bad. Might remove the airbag and have a look at these.


Sent from my iPhone using Tapatalk
 

mossyv6

ClioSport Club Member
  Trophy,V6,5GT,AG200
I have had the exact issue before. Replacement set of steering wheel switches sorted it.
 

182.tbv

ClioSport Club Member
  Clio 182 FF
I have this issue with an aftermarket wheel and buttons. No airbag, no airbag light. Is the brake switch the same as for the brake lights? Anyone got a link/part number please?
 
  Westfield, 182, 200
Brake switch, just reset it.
Had this on my 182 for ages, rest the brake switch and it was perfect.
Couldn't believe I hadn't tried it months ago!
 


Top