Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Mobius Cam help - PC wont recognise it??

As above. Things doing my nut in now.

Bought the Camera.. Took a class 10 32gb SD card out my Cyber shot, before this i formatted the SD card to just FAT32 before putting in the mobius.

Put SD card in mobius, used their online instructions into how to use the cameras formatter (hold down mode, disconnect, flashy lights bla bla) but my comp still wont bring it up?!
Ive downloaded their mSetup.exe and it simply wont recognise anything "Please connect your camera to a USB port" it is! its a laptop im using so no USB hubs.

It shows as "Removable Disk F" on the computer but its greyed out, click on it, "please insert a drive to disk F". I can record on the camera fine! Put the SD card into my TVs SD reader and it plays back these random snippets ive made fine.

Put the SD card back into the cyber shot and plug that in the comp and mSetup shows it up but obviously its in a sony cam and wont have it.
Put back in the mobius and nothing?!

Used the USB cable it came with and a different USB cable of same sort. both unlucky.

Whaaaaat the fxk.
Help before i cry.

Edit: i also follow the instructions online into how to connect it via USB. Camera is turned off, then i plug it in. So its not on before i connect this shiz.
Last edited:
  mk1 Octavia VRS
Sounds like an issue with the laptop. What OS is it? Can you try it on another machine? Have you tried plugging the Mobius in without an SD card in it?

Might not be related but what SD card is it? If you have a cheap/unbranded one I would recommend getting something half decent like a SanDisk Ultra or equivalent Samsung. When formatting the card you should use the device's built in format option, not the Windows formatter.
Using windows 7, could try it on my brothers comp but need to find time to get down there.

Used 3 different USB cables now to still no avail with or without the SD card plugged in.

The SD card is generic but got a Kingston on the way now. Might be a problem using a generic one but it can record onto it fine and I can access the files fine if plugged in internally by itself.


ClioSport Club Member
  RB182, 987, Lupo Gti
Also try formatting it with sdformatter, windows still can't handle SD cards correctly