ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

New country! New whip! (Jap content)



Jealous. For the lols' , I think I'm gonna get an insurance quote on one of these later. I'd feel like a proper 'G' (as they say....) if I was 20 and had a skyline! Feel pretty good being 20 with a clio sport LOL.
 
Jealous. For the lols' , I think I'm gonna get an insurance quote on one of these later. I'd feel like a proper 'G' (as they say....) if I was 20 and had a skyline! Feel pretty good being 20 with a clio sport LOL.
Haha tbh I still want a Clio as my daily driver, really miss my 1.2 surprisingly haha

Never thought I'd have a skyline as my 2nd car at 18 D:
 

Matt W

ClioSport Club Member
  E92 M3
Jealous. For the lols' , I think I'm gonna get an insurance quote on one of these later. I'd feel like a proper 'G' (as they say....) if I was 20 and had a skyline! Feel pretty good being 20 with a clio sport LOL.
My mate in NZ had an impreza wrx at 17. Insurance isn't compulsary!
 
Ok so I've given it a clean and have noticed some things!

First thing are the wheels... They're DTM wheels which I think are pretty good aha, they're on 235 tyres so pretty wide, but the rear wheels look like this:

null_zpsbc66a703.jpg


null_zpsa5663d39.jpg


There any way it could be saved? Or do they need a refurb?

Also noticed there's a switch under the steering wheel next to the turbo timer... I've tried switching it when the engines on, and when it's off and it hasn't done anything obvious.. Any ideas?

null_zps4b7f2c62.jpg


null_zpsdcdb7598.jpg


Also tried to dry out the condensation on the tail light, but I can't see it lasting long!

null_zpsbcd7ac59.jpg


These cables are starting to piss me off... Could it be HU related wires? Noticed the previous owner left the wiring kit for a sub in the boot still hooked up to the battery

null_zps3deb800e.jpg


And for those of you that think you have bad swirls... The dealers are stupid over here, the machine polish the cars, but it only makes it worse and creates loads of holograms too. Grr!

null_zps0fac8d01.jpg


null_zps22f0a472.jpg


null_zps43c6ec26.jpg


null_zps5ba19f63.jpg


(Excuse the water on the bonnet)

null_zps8501bcd2.jpg


Also noticed this in the drivers side rear quarter... Any way this can be saved? I tried some swirl remover... Didn't do much!

null_zps255766a8.jpg
 
Is the switch for a rear fog?

Those wheel lips are corroded, they'll need refurbishing mate.

Those other cables could be from old turbo timers, toll card readers etc.
The temp gauge isn't working and there are drill holes on A pillar, could he have had another temp gauge on the A pillar?
 

Rob

ClioSport Moderator
Put some time and effort into sorting out that wiring, that looks f**king terrible.

Wow at the swirls though, wow.

You got a polisher? That'd be seriously rewarding!
 

Rob

ClioSport Moderator
You're a brave man buying a car you have little knowledge of, with no local community to help you out (yet).

Go find yourself some car friends, sharpish.
 
You're a brave man buying a car you have little knowledge of, with no local community to help you out (yet).

Go find yourself some car friends, sharpish.
Yeaa there's not even an active nissan forum out here :/

Well I didn't know anything about the Clio before I bought it? I don't really research tonnes into details before I buy a car, only common problems etc. I went to a NZ Honda meet last night and they seem pretty cool and know their stuff so might go to a few more of their meets
 
If you set the turbo timer for like 10 seconds, the turbo will still spool for 10 seconds after the engine is off iirc...
IMO not a big fan of the wheels though throw some Rota Grid Drifts on there or something ;)
 


Top