ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Unusual Tyre Wear and Disc Issue



  Williams 2 & 200
Right I have a couple of issues and I have tried searching! Basically the inside edge of both tyres are bold, i've just had the tracking done and the pass side was well out but the drivers side was seized, the pass side has now been sorted but could the passenger side cause problems with wear on the drivers side and do you think there is anything else i should check?

Regarding the brakes I changed both front pads and discs but the outer pad on the pass side is not gripping the entire disc. I've re-stripped the brakes and re-assembled and everything seems fine so i'm not sure what could be causing this apart from a non flat pad surface?
 
  Clio 197
Right I have a couple of issues and I have tried searching! Basically the inside edge of both tyres are bold, i've just had the tracking done and the pass side was well out but the drivers side was seized, the pass side has now been sorted but could the passenger side cause problems with wear on the drivers side and do you think there is anything else i should check?

Regarding the brakes I changed both front pads and discs but the outer pad on the pass side is not gripping the entire disc. I've re-stripped the brakes and re-assembled and everything seems fine so i'm not sure what could be causing this apart from a non flat pad surface?


tyres has got to be a tracking issue, have you replaced the tyres to see if the problem is still occuring? have you had the drivers side sorted now?

re: pads, what pads have you gone for? reason i ask as if its some ebay specials complete with discs then i fitted these to my girlfriends 147 and the pads where a shocking fit - i ended up binning them. If not then it must be down to fitting error, did you clean the sliders up and remove any crap with a wire brush and check the sliders operated ok without sticking?
 
  Williams 2 & 200
Cheers for the reply, tracking was only done this morning so i'm, hoping that has sorted the wear on pass side and drivers side (as this wasn't out much). I've got about 2-3k left on the tyres so i'll get the drivers side track rod properly sorted then i think.

The pads and discs are from Pagid and the other side to the issue is fine its just the one pad which is causing the issue. I cleaned the sliders and with the wheel off and me pressing the pad does seem to make more contact but once the wheel is on this stops so really scratching my head on this one. If this doesn't sort itself out I'll spend some time trying a few things at the weekend but it really isn't obvious!
 
  RenaultSport 172
If the pad is poking out of the edge of the disc you'll probably have to file the edges of the pad.
 


Top