Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

  • When you purchase through links on our site, we may earn an affiliate commission. Read more here.

Clio Mk1 (Williams) Heater Blower not working

  Clio Williams 1
I've just joined the Clio club with a Williams 1 (and really happy with it!) and need some help with the heater blower. I've discovered it's not working on any of the 3 speed settings.
The fuse is fine and the multiplug cable is reading 13.8v on the +'ve which sounds ok but not sure what the working range is.

The multiplug connector pins on the blower look ok - visually at least.
Is there anything else I can check or would it definitely be the blower?

G Hut

ClioSport Club Member
  ph1 172, V90 T8
Yes it will be, prob under scuttle at front not sure where on that model, quick Google should reveal for you. Likely a thread on here also just search
  Clio Williams 1
Tried power directly from the battery to the blower (having removed the resistor pack) and it worked. Resistor pack replaced and all back up and running. Thanks for the advice.