ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Mk3 Clio radio and clock not working.



  2006 renault clio1.2
Radio has suddenly stopped working. And the clock on the dash isn’t working only light which comes in is the seatbelt light. I have checked all fuses even changed the 15amp radio fuse. Absolutely nothing, I recently changed the interior light to a brighter one so not sure if that has anything to do with it. All cables going into the radio are all connected fine also. Help!
 

MRBILLYUK

ClioSport Club Member
  FF Jeden Osiem Dwa
Tbh I haven't got a clue what's wrong.
Have you tried putting the original light back in and see if that makes any difference?
It might just be a coincidence that your radio stopped working but it's worth a try.
 
  Clio 2.0 138hp
Did you replace it with an LED bulb by any chance. Lots of LED bulbs cause issues due to the canbus system. Stick a normal filament bulb back in and see what happens
 
  2006 renault clio1.2
Yep I tried that. Scratching my head about it to be honest. I only have 1 fuse underneath the steering wheel for the radio I’m not sure about the engine as I read up there are fuses there, near the battery under a cover or something but there 30amp etc
 
  2006 renault clio1.2
Still no luck. Tried with out the bulbs in with only 1 in put the old bulb in. Still nothing I’m not sure if the radio could be just dead or what
 
  2006 renault clio1.2
So it’s still not working. Got myself a multi meter and the fuses are fine. Checked all fuses in the engine bay also and all the fuses are fine... really can’t get my head around it. It’s a Clio 2006 1.216v expression. I’ve heard there’s fuses in the glove box and some hidden near the cup holders ect
 


Top