ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

N/S creaking noise on fresh suspension



  "Navy" N17 TWO
Have a strange creaking noise coming from my front left wheel area

Recently had new 172 Cup shocks & Cooksport springs fitted with standard mounts
All bushes are powerflexed
New wishbones about 10 months ago with new inner & outer track rod ends

Don't get this all the time, but it sounds like an old creaky floorboard even on smooth roads at low speeds and can be very loud too when on/off the brake pedal

Brakes also freshened up last summer with resealed calipers


Any ideas?
 

Martin_172

ClioSport Club Member
check the bottom arm to subframe bolts are tight saw that cause odd noises if they have came loose.

powerflex bushes however do creak unless you keep them greased up apparently but ive never used them
 
  "Navy" N17 TWO
Cheers - she's going in to have the belts done tomorrow so will ask them to have a wee look
 
  "Navy" N17 TWO
Got the 2 front wheels off the ground and gave them a few turns in both directions - o/s sounds fine :)

n/s sounds like shaking a bucket of LEGO! :(
 
  "Navy" N17 TWO
Still have this creaking session - lots of squeaking on a good B-Road blast and even smooth roads around town at 30mph and less

It's had a health check when it was in Renault having the belts done. Their comment on the checklist "Passenger front shock seems weaker than drivers front"
 
  clio sport 172 ph2
I'm a new member to clio sport from Edinburgh and im lovin my sport 172. Just a wee question for tigger, did you find the problem with your creaky suspension, I've got the same problem but on new standard shocks and it's pulling to the n/s.
 
  "Navy" N17 TWO
I've found that one of my metal sleeves on the wishbones has moved as it wasn't spot-welded when fitted. (Powerflex bushes- purple type)

I do get a strange rubbing sound occasionally on the offside too - think it's an arch liner though
 
  clio sport 172 ph2
Found the problem that was causing the creaking. 3 loose subframe bolts and a loose wishbone bolt which I would imagine has caused my front n/s tyre to wear unevenly.
 
  "Navy" N17 TWO
Mine sounds like a haunted house in traffic
- every little movement makes a squeaking/creaking from the arches somewhere. Even more-so when I'm on & off the brake pedal
 
  Mk2 172
I've got this, from doing a bit of reading it might be the Top mounts at fault. I'll have a look at mine at some point and let you know if it solves the issue. I can't find the thread now, but it was something to do with a revised top mount design and some people had used washers to stop the creaking.
 

Martin_172

ClioSport Club Member
I had a similar issue on a car I was having a look at for a boy recently, turned out to be a loose inner track rod, it had been replaced by a garage a few months prior :S

could have been nasty, I was stumped as you could feel it through the wheel and it was worse on rough roads or under braking
 


Top