ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Valver Wiring Questions.....+Gearbox



  www.renparts.co.uk
Bought a valver off a numpty for 300 quid. He has just put another engine in it from a crashed valver which is hit mates so i know the engines strong.

1) Problem is he has started putting a different loom in (god knows why). I have a complete loom ready to go in but i just wondered if there is a guide available on fitting this (IE where everything plugs in). Ive got good mechanical knowledge so im generally pretty good but im all new to this. just looking for some tips.

2) he has misplaced the ECU when he fitted the new engine will any valver ECU be ok? He thinks he has 2 back at his workshop so im just hoping i can use either and they will be ok.

3) as its not running at the moment i sat in the car and tried to select each gear. When you let go of the stick in neural it springs to the right rather than the middle. Reverse and 2nd also don't seem to be able to select. Is it the way the slector rod has been fitted? or sound like something else?

thanks
josh
 
  S2000
1) Don't think there will be a guide as such for the loom but you will have to make sure it's the right loom because iirc theres 3 different looms for valvers.

2) I think any ECU should work but if you use a Ph1 ECU on a Ph2 valver then the immobiliser won't work, similarly I don't know if a Ph2 ECU will work with a Ph1 - best bet is to wait on someone else confirm this but if you need an ECU PM me as I have one for sale.

3)it'll probably just be that one of the returning springs has come off the slector rod causing it to go to the right. IIRC you can see them just behind the heatshield above the car. I'm not totally sure about the problems with reverse and 2nd but I think it is possible that it just wasn't fitted properly. If you get a haynes manual it'll tell you how you adjust it so that it works properly.
 
  S2000
yup, as Amir said it's a ph1. The ECU I have here is out of a ph1 as well and it's yours for £15+ P+P if you want it.
 
  www.renparts.co.uk
how will i know if the replacement engine is ph1? the looms i have both look exactly the same. seems a waste of time changing them over if theyre identical. What will the differences be in the ph's of looms?
ta
josh
 
As far as i am aware the engines in diffrent phases are the same.

As for being dodgy going into 2nd and reverse thin thats jus a common thing ith the f7 gearbox, mine does it aswell.
 
  www.renparts.co.uk
Right cool. Just wondering why the previous owner had started putting a new loom in when the other was fine. Looks like the old loom will be suitable providing the engines like you say are the same. I think the selector rod has been setup wrong. If it needs a new box no biggy, you can pick em up for 50 quid can't you?
ta
josh
 
  S2000
there is a definate difference between the looms, but I'm not sure how you can tell. Best bet is to ask the likes of winston and matbrown as it was them that made me aware of the different looms when I thought I was going to need one for the 16v. I would think you could find out from the engine code which would be the correct loom. Chances are the problem with the box is just the selector. If it was able to select 1st and reverse but not others you would be looking at a problem with the box, but if revers is a problem then it's probably not been set up properly.
 


Top