ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

03 1.2 16v twitchy as hell a*se end



Okay so a few months ago I slid my clio into a curb in heavy rain. Long story short, the beam was changed for a second hand one and all looked good.

Ever since its been on though the back end has been twitchy as fook. Something didn't feel right. so my mechanic friend and I checked the back end out and couldn't find any thing wrong. Bearings all fine, everthing running true, shockers not leaking, pressures equal. All good. Only thing we found that deviated from the norm was the fact the rear is toeing in 2 degrees. this is only slightly out of renault tolerences so we thought all would be good. I was told I was imagining it and to just get on with it.

But today I really noticed it in the wet. It just felt down right dangerous. This was confirmed as I had it broad slide down the M40 this morning and I was only doing 60 and driving safely. It just didn't want to play in the wet.

So any ideas? have I missed something? Thanks
 
  alien green rs133
fill boot with lead, or a huge steel donut that you can fill with a liquid gas :D

sorted my back end out

ps mines on lpg :D
 
running the standard conti's on the back.

Edde, do you think the new beam is bent if it's toeing in that much? was assured it was okay when i got it. sure renault will screw me for a new one
 
running the standard conti's on the back.

Edde, do you think the new beam is bent if it's toeing in that much? was assured it was okay when i got it. sure renault will screw me for a new one

you find loads of second hand beams are bent

best do find a car which has had a fornt end as the rear beams do get bent often in crashes a fair bit,

Check your cars front end though as well also might be worth rottating the tyres.
 
Want a laugh, renault just quoted me £570+vat for a new beam. Thats just for the part with nothing on it!!!!!!!!!!!!!!!!!!!

Gonna get hold of my mates laser tracking set and see whats what next and go from there! Cheers for the suggestions guys!
 
i did the same mate. needed a new rear axel etc...

mine felt twitchy as hell in the rain, i darent switch lanes on the motorway.

ive recently bought new tyres all round and it feels back to normal again...


are u wearing budgets?
 
I bent a rear axle few years back. Had major problems in the wet it would lose it on roundabouts at 15mph. Turned out to be a bent shock didn't appear to be leaking though.

If it does it more turning one way than the other might be worth swapping them over to see what difference it makes.
 
actually i forgot that i had my steering rack replaced!!

that is the thing that sorted out the shitty twitchy-ness. Also had bushes done too ( wht ever they are) but apparently they contributed to it too mate.
 
Got conti premium contacts on the back but they are a bit low.

I did muller an alloy but have replaced that and had it all balanced. Everything looks fine externally, everything runs true so just gonna have to check the geometry and see if anythings moved. Thanks for the help
 
Okay, the replaced beam is fooked. laser tracked it today and it's toeing in about 9mm each side! Front was fine. Anyone got any straight beams laying about? I'm sure as hell not going to renault who want £600.
 
UPDATE: Have fitted a 2nd rear beam now and all is lovely again. Not sure what its off as it has drums but a thicker antiroll bar. Oh well. tis back to how i remember it, some new tyres sometime this week and it should be super stuck to the road.
 


Top