ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

172 CUP Track Car



Chambers_RS

ClioSport Club Member
  Clio 172 Cup&Leon K1

Chambers_RS

ClioSport Club Member
  Clio 172 Cup&Leon K1
So fuel tank is back on after been cleaned out etc. New feed unit installed with the walbro 255 pump and roll over valve fitted to the breather.
Exhaust is also back on.

Need to sort the fuel hose out, could see any route over the tank for the hose to run without it being trapped or pinch by the tank/body.

8EC0C573-9AB0-4535-8389-95E995139CE0.jpeg
08832990-AE13-4398-9BF7-4A12BAD39137.jpeg
 

Chambers_RS

ClioSport Club Member
  Clio 172 Cup&Leon K1
Cars back on its wheels. Brakes all done, exhaust lined up and carbon trim suck on.

Just need to torque the hub nuts and wheel studs.

1077DED6-D460-46BD-990F-C4DA9D0B76A5.jpeg
68F135FB-BF19-4BC2-9C93-26C041EE7462.jpeg
7C176E65-110E-430E-9D4B-95BECA9D688A.jpeg


You can just make out I’ve setup the throttle linkage. How does the cable attach to the pedal?

I’ve also fitted my cartek cut off, as I need to make sure the engine turns over ok. 12.7volts at the battery, only 0.75 in the engine bay 🤦🏻‍♂️

C54DC751-3095-4BEB-AF84-2F3E3315BD57.jpeg
CA4AA2BF-EDC8-482B-AEAD-535830C651BD.jpeg
 
  172 cup, x5, racekor
keen effort for painting the roof scoop. i had to remove it before and just cut the sealant. cleaned it up and rebonded it as required.

making good progress though mate!
 

Chambers_RS

ClioSport Club Member
  Clio 172 Cup&Leon K1
keen effort for painting the roof scoop. i had to remove it before and just cut the sealant. cleaned it up and rebonded it as required.

making good progress though mate!
haha cheers mate. The inside of the scoop is still yellow 😂

what you got now?
 

Chambers_RS

ClioSport Club Member
  Clio 172 Cup&Leon K1
I need to get a TPS for my Jenveys, can I get this wired into the OE loom does anyone know? And can I use the OE air sensor?
 

vroomtshh

ClioSport Club Member
  Seat Ibiza Cupra TDi
I need to get a TPS for my Jenveys, can I get this wired into the OE loom does anyone know? And can I use the OE air sensor?
My TPS has 3 wires coming off it that connect to the existing loom. I just used a superseal connector so it can be plugged in or unplugged to remove from the car.
OE air temp sensor works fine
 

Chambers_RS

ClioSport Club Member
  Clio 172 Cup&Leon K1
My TPS has 3 wires coming off it that connect to the existing loom. I just used a superseal connector so it can be plugged in or unplugged to remove from the car.
OE air temp sensor works fine
Sounds like what I’m looking at. 3 wire Jenvey TPS but the Oe loom is 6 wire if I remember correctly.
Don’t suppose you got a picture of yours?
 

Chambers_RS

ClioSport Club Member
  Clio 172 Cup&Leon K1
Not sure where I am with keeping this updated but I’ll do a quick up date.

I’ve got a new torque wrench, one that’s capable of torquing the front and rear hub nuts. So that’s now done
59545F50-B7A0-4697-AFA6-8F08DAD544DF.jpeg


I’ve pulled all the interior loom back in so I can make a start on wiring the 044 pump and getting the engine to at least turn over for a compression check.
FCFEC426-C5DD-45CE-804F-5BCB66A586B6.jpeg


replaced the chassis to box earth strap with a genuine Renault part

ED39745E-59C4-4BD5-8F8A-C532D906B8D6.jpeg


filled the engine and box with oil, also added antifreeze.
04CAE49C-051F-4BD5-9728-2F9393545DD5.jpeg
C92B25A5-6F25-4C8F-824A-21ED8A5A4226.jpeg

FBE1DBFC-5104-4DC8-B624-3A5E4B0DFD85.jpeg


this is where thinks got annoying.

first off I had a leak from my heater bypass hose.
16604521-74B7-4ED8-B19C-52A2DF761E72.jpeg


when I built the engine on the standI replaced the complete water housing and stat housing for a new Renault part, but for some reason the hose wouldn’t clamp down enough. So removed and check on the old part and it was a snug fit. So I ordered a 16mm U bend and a 19mm-16mm reducer to connect to the forge coolant hose and this was cured.
3AF47AD0-7133-4666-911E-3521BB78CB46.jpeg
 

Attachments

Chambers_RS

ClioSport Club Member
  Clio 172 Cup&Leon K1
Once that was done I topped the system up
With water and started pressure testing it.
all seem good till I noticed a weep from the plastic coolant pipe from the block to the bottom hose which ended up with this happening.

C9DDCC7A-0E9C-463D-BD2F-70196A14247F.jpeg

3110A280-86BC-4EF0-9CF0-E394883206E5.jpeg


This is how it’s been left. As I’m debating how to tackle the leak as the plastic hose is such a pain to get to. Everything from the rad, oil cooler hoses, rad hoses, fans, subframe, alternator and ITBs are in the way 🤦🏻‍♂️

Can see the slight weep on the blue roll

D97ACF7C-9908-4396-AD23-5ED30A3D51A3.jpeg


and a better picture of the pipe

EDF4106B-181A-4F1A-8F3D-2739D75BF82A.jpeg


I may need to remove all the rad, fans and oil cooler to get to it but still won’t have any idea it’s fix till I put it all back together and test it again 😪
 

Chambers_RS

ClioSport Club Member
  Clio 172 Cup&Leon K1
I always thought this pipe could be a weak spot. I siliconed mine in as I built the engine. They're not easy to extract from the block though, especially without removing the water pump.
Sorry, not very constructive I know. But I do sympathise.
😂
I didn’t think silicone would of been necessary when I fitted it. The plastic pipe was crack so had to replace it and the seal with a new Renault one. What a pain it was it get out and fit even in the stand.
The pipe so tight I thought there would be no way it’ll leak 😂
 


Top