ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

182 brakes not working well



  Ford Focus ST2
i have found that my brakes on my 182, not working very well. they used to be very good but it seams there not working correctly, i can put my foot flat on the brakes, it well stop me but not lik they used too (seams like its not stopping you fast enought for the ABS to kick in!!!) Looked at the disks and pads (all standard) and they look fine. whent to check the brake fluid and could not find it under the bonnet!!!???

any ideas?



Rob
 
  tiTTy & SV650
when looking at the engine from front of the car the brake fluid is in the back left corner, need to get the engine cover off to see it.

mine were feeling crap but bled some air out the lines and new pads all copperslipped up and voila like new again
 
Probably glazed pads. I've found the pads tend to glaze if you don't use the brakes hard.

Find a nice straight long and empty road, and do a few HARD high speed stops. That should sort them out :)
 
  Mercedes SLK350
Roy Munson said:
Probably glazed pads. I've found the pads tend to glaze if you don't use the brakes hard.

Find a nice straight long and empty road, and do a few HARD high speed stops. That should sort them out :)

I have had this happen a few times.

Usually I remove the pads and deglaze them with emery cloth on a flat surface.
 

Ad

  MK2 FRS
its possible, also could be a pad seperating from its base. Happen to sokett, but took then a while to find it.
 


Top