ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

I’m home!



mgregson1980

ClioSport Club Member
  On the hunt!
After ten years of owning various fast Clios - 2 x Williams, R27 and Ph 1 - then a 6 year gap to get married, have a baby and buy a house, I’m finally back in one!

I’ve just picked up this Phase 1 172. I bought it on the back of a video and it was trailered back to Kent from Yorkshire today, straight to my bodyshop to sort some minor issues.

The bodywork and condition is a credit to its former keeper and it came with plenty of history. It’s not been on the road for a few years, but it’s a great base for a project and has no major issues at all.

Next stop is the cam-belt, dephaser, service and MOT.

I’ll also likely be putting it back to standard, as it has a Momo wheel, PMS top mounts and brace, KTec Stealth, standard 172 alloys etc.


Sent from my iPhone using Tapatalk
 

mgregson1980

ClioSport Club Member
  On the hunt!
57c1c16c8e1599f43529ccfa2be92bf9.jpg



Sent from my iPhone using Tapatalk
 

mgregson1980

ClioSport Club Member
  On the hunt!
Welcome back and looking forward to seeing another phase 1 brought back to life and in use

Thanks mate. You were the only name I recognised on here. You used to be on Clio Williams too, right? I remember chatting to you and Northy back in the day! Probably ten years ago!


Sent from my iPhone using Tapatalk
 

Coops Mk1

ClioSport Club Member
  Lots of Scrap...
Thanks mate. You were the only name I recognised on here. You used to be on Clio Williams too, right? I remember chatting to you and Northy back in the day! Probably ten years ago!


Sent from my iPhone using Tapatalk

Yes mate I've been about since 2004 ish and was active on williamsclio forums back then. Still got a couple of mk1's and the phase 1 172 and a 182 as well that I daily. Never grown up tbh, lmao
 

mgregson1980

ClioSport Club Member
  On the hunt!
Is that lagging standard on the Ph1’s at the rear of the engine bay? Looks like a highland cow has died back there...

Welcome back, btw!

Yeah, the matting is standard. It used to be black, but I’m guessing that the colour has come off or faded. I’ll likely switch to a metal heat shield anyway to clean up the bay!


Sent from my iPhone using Tapatalk
 


Top