ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Oil warning light problem



  TVR Cerbera
I hope you can help....when i turn on my ignition my warning lights all come on then some go out (which i think is normal) but the oil pressure warning light goes out too! (engine not running!) i noticed it when i changed the oil cos on most cars the light will stay on for a bitand i was looking for it to go out and it was never on! i thought bulb is ok cos it lights up on initial switch on and therefore assumed it was the pressure switch....nope still the same. i've tried shorting the wire out to earth to simulate low pressure but that doesn't put it on either. now i'm stuck.

Can i ask you guys to either confirm the same or different symptoms on your clio dashboards please or a way to fix the warning light, because to my electrical knowledge if i have low pressure at the mo the light will not come on!!!


Thanks Daz
 
  BMW M135i
I've noticed this too, in all the cars i've seen before the oil pressure warning light will say on until you start the engine and the pressure builds up. But not in both the clios i've had, think it has something to do with the fact that its got the electronic oil gauge so it goes off that until its started.
Thats my theory anyway. Doesn't help when your trying to work out if the pressure switch is knackered and sticking on.
 

MRBILLYUK

ClioSport Club Member
  FF Jeden Osiem Dwa
Sounds normal to me . When you put your key in the ignition and turn , all the lights come on , start the car all the lights go off , except for the handbrake light obviously . Thats what its like on my 182 , was the same on my 172 .
 
  TVR Cerbera
MRBILLYUK said:
Sounds normal to me . When you put your key in the ignition and turn , all the lights come on , start the car all the lights go off , except for the handbrake light obviously . Thats what its like on my 182 , was the same on my 172 .

Could you see for me if the light goes out if you don't start it, please

Daz
 

MRBILLYUK

ClioSport Club Member
  FF Jeden Osiem Dwa
Greenys_meanies said:
Could you see for me if the light goes out if you don't start it, please

Daz

I couldn't remember off the top off my head exactly last night what lights went out .

Just got the car out the garage . With the key turned but the engine not started , all the lights go out except the stop light , handbrake light and battery light .All the lights that do go out including the oil light go out within about 1 second .Then when the engine is started the battery light goes out .

Just checked the clio manual and its right . The oil pressure light should go out straight away .
 
Last edited:


Top