ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Throttle not working



  Clio 182 cup
Was driving the 182 earlier today when it just lost all acceleration then the engine started to idol its self at between 2500rpm and 3000rpm and the throttle peddle wasn't responding but the throttle its self was still opening and closing each fine time it got pressed just wasn't letting the car rev the electric service and check engine light all came on at the same time managed to drive the car home just using the clutch and the high revs on the engine any ideas what the issue is before I start just pulling parts off to check
 
  182 clio
Was driving the 182 earlier today when it just lost all acceleration then the engine started to idol its self at between 2500rpm and 3000rpm and the throttle peddle wasn't responding but the throttle its self was still opening and closing each fine time it got pressed just wasn't letting the car rev the electric service and check engine light all came on at the same time managed to drive the car home just using the clutch and the high revs on the engine any ideas what the issue is before I start just pulling parts off to check
Is the engine management light on?
Get codes if so
 
  Clio 182 cup
The engine management light came on but after I turned the engine off and on it went back off again but the electric light and service light stayed
 
  Clio 182 cup
Plugged it in no codes came up but as soon as u turn the key it idols at 3000rpm straight away and tried swapping pedals from my palls one still didn't work so will start to check wiring tomorrow see if I can find a break somewhere will post up if I see or find anything on it
 

Brigsy

ClioSport Club Member
  Kangoo 172cup
Get clip on it faults will be stored. At a guess its throttle body or wiring to it
 

Brigsy

ClioSport Club Member
  Kangoo 172cup
We plugged it in but only done a quick scan and nothing came up so will try that again tomorrow then check everything over
What code reader are you using ? Generic obd scanners dont usually show much
 


Top