ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Ecu Unlocking



  Astra 1.9Cdti SRi
Need some bit of info on this if you dont mind,

Been speakin to someone about my car not starting up and told him that renault have it now and they arnt 100% they can get it to start up. So he then mentioned after going through everything from injectors spraying to coilpack, Ht leads etc that it could be the Ecu thats locked. Now before i could go into more details the conversation had ended and then i though about more questions i could ask :eek:

So what does a Unlocked Ecu mean?

does it simply mean that when i get it, it will be unlocked but as soon as its hooked up to mine it will then be locked on and working ?
 
what engine is it?

If the immobiliser is active (ecu locked) the injectors will not fire at all, the coil will not spark either...as they are the two points generally used to immobilise the car.
 
  Astra 1.9Cdti SRi
Its the F4R fella, its mine and the damm thing still wont spark.

The injectors do fire, the fuel pump does prime, its the coil pack that doesnt give nothing out,
 
Tried a different ECU?

If the ECU was locked (immobiliser active) the injectors will not fire, so im guessing it cant be that. had this many a time on mine before, in the end I ran an emulator on the ECU to f*ck the immobilser off all together. Never had a problem since.

Are you trying to run the UCH too or something?
 
  Astra 1.9Cdti SRi
I bought another Ecu from Rm bailey on here which also came with Uch/Barrel/decoder ring etc, and still the same just turns over every time.

The immobiliser light goes off and injectors spray, i was told that if the fuel pump doesnt prime it will be immobiliser issue hmm,

I have the UCH plugged in yes, though it was mandatory to have it plugged in tho?

Emulator?
 
  BMW M5 & E36
Is it a Ph1 or Ph2 engine? Rm bailey was breaking a cup IIRC, so if you're trying to use a ph2 ecu on a ph1 engine/loom that could be an issue...
 
For a start, the ECU (regardless of weather the immobiliser is active or not) will always prime the pump, and run it on cranking.

If the immobiliser is ON...the injectors will not fire, and the coilpack will not spark (the coil will receive 12v from the ECU, but not earth it to spark).

If the immobiliser is off, the car *should* start...and you say the immobiliser light goes out, which is good. Although it all points towards you having a wiring fault, or an ECU hardware issue...or something else UCH related.

Have you checked if the two wires on the Coilpack connector have continuity to the ECU? If they dont that could be a problem.

TBH the whole decoder/UCH/immobiliser setup is messy and has to be spot on for it all to work. IMO the easiest way (which you could have done from the start) is to buy an emulator for the ECU (£35), get your ECU virginised (£70), then fit the emulator and it would start first time if everything was correct wiring wise, and there were no faulty components anywhere else. This basically gets rid of the shitty renault immobiliser...if you wanted one on the car just get an alarm with one built in too.
 
  Astra 1.9Cdti SRi
Whiteley, Its a Mk2 engine from a 2002 172,

Right thanks for clearing abit of stuff up there fella, now pointing towards the coilpack connector have continuity to the Ecu, What exactly do you mean here, i dont want to get another loom and find its not goin to work once again,


If the emulator for the ecu will deffinatly work and get it virginised start the car, then i will do that, iv spent over 1500 so far doing this, i just want it up and running now.

Any contacts to get the work done jord?
 
Emulator - http://www.tek-tronics.co.uk/product_info.php?products_id=80

Paul @ RSTuning can Virginise it, as well as any other ECU decoding place really (just dont use ECU Clinic), google for them! If you find someone and they ask what you want doing, just say you want it Virginising.

Once its virginised, fit the Emulator to it....that will ensure the ecu is definately OK and its not an immobiliser issue. If it still does not run then, something else is amiss
 
  Astra 1.9Cdti SRi
Cheers il save that link now so i can order that as soon as i get the car back from renault, as i kno they wont have any luck because when i phoned today he said theres alot of un=used wires there, so i had to explain why, ffs renault.

It looks like you have to open the Ecu up right to fit the emulator...

Il wait till i hear back from renault first jord, and if i get no luck il try your suggestion

Il report back in next couple of days :)

cheers for your help
 
  Fiesta ST-3
Whiteley, Its a Mk2 engine from a 2002 172,

Right thanks for clearing abit of stuff up there fella, now pointing towards the coilpack connector have continuity to the Ecu, What exactly do you mean here, i dont want to get another loom and find its not goin to work once again,


If the emulator for the ecu will deffinatly work and get it virginised start the car, then i will do that, iv spent over 1500 so far doing this, i just want it up and running now.

Any contacts to get the work done jord?

Sticking the F4R in my Megane coupe. Not got to your stage as of yet but i had my ECU decoded by RSTuning for a total of £75 deliverd back to my door. The car is currently at AP-Developments in Swansea to get the thing running. Hes doing all my wiring which includes splicing the Megane Loom to the Clio so just a thought mate as your from Wales right?
 
  Astra 1.9Cdti SRi
Mate in all honesty from what others have done etc i dont see why im gettin all the problems, at first i bought the engine etc and loom ecu the lot, so should be a easy job.

Now what i dont get it, say you have just blown your engine in your 1*2, you get a replacement engine and it should fire up straigh right? well thats mine basicly, but not firing up, it just doesnt make sense,

The amount of money i have spent on the car in total i could have bough a good much better car, but i want my project to be finished.

Ap-developments doing all the work for you?

i will contact Rstuning as soon i hear back from Renault, hopefully tommorow, and if they say nope no luck il pay the bill and do what foxy mentioned.

Aye im from Wales, just waaay up north its about 5hours to go down to Swansea,
 
  Fiesta ST-3
Mate in all honesty from what others have done etc i dont see why im gettin all the problems, at first i bought the engine etc and loom ecu the lot, so should be a easy job.

Now what i dont get it, say you have just blown your engine in your 1*2, you get a replacement engine and it should fire up straigh right? well thats mine basicly, but not firing up, it just doesnt make sense,

The amount of money i have spent on the car in total i could have bough a good much better car, but i want my project to be finished.

Ap-developments doing all the work for you?

i will contact Rstuning as soon i hear back from Renault, hopefully tommorow, and if they say nope no luck il pay the bill and do what foxy mentioned.

Aye im from Wales, just waaay up north its about 5hours to go down to Swansea,

I know what you mean mate dont get me started on problems lol. AP-D doing all the work now mate yea because we had just had so so many problems thought id bite the bullet get it finished proffesionally. Good luck :)
 
  Astra 1.9Cdti SRi
if ap dev will virginise the ecu send it to me and ill pop it up (if it can be done with out the car ofcourse)

Nah Dan, il get a proper Ecu place to do it, need it to be a top job :)

just wait and see, il get some news tommorow hopefully
 
  Astra 1.9Cdti SRi
Nope man, its been approx 4months to yesturday since it last ran, im using dads car at the moment but have to hand it back sometime next month, which is a bummer :( so i have to get it up and running..
 
  Meg'd r27
What kind of signal are you getting to the coilpack, might sound silly but have you checked the fuses and relays, earth straps
 
  Astra 1.9Cdti SRi
Earth straps have been checked, i was thinkin that i had probably forgot to connect a earth somewhere, so whipped out the loom and did it part by part and yes i did forget one, so i connected and tried and no luck.

I dont get this signal to coilpack tbh, on the connector to the coilpack theres 4 holes with 3metal inside, 1 is live and 2 signal, i do have power in that 1 pin,

Could the Ht leads be firing in the wrong order? but that still shouldnt cause it not to spark tho.

Fuses all checked some have been replaced,
Relay's have been swaped over from what i had on the 1.2 as i knew they worked,
 
I dont get this signal to coilpack tbh, on the connector to the coilpack theres 4 holes with 3metal inside, 1 is live and 2 signal, i do have power in that 1 pin,

you should be getting 12v constant or thereabouts on cranking on that one wire.

the other two are earths. The ECU earths them one then the other in sequence to create the spark
 
  Astra 1.9Cdti SRi
if it ran before it wont be an ECU immob issue, are you sure the coil isn't just shafted?

Engine does work, as i bought it in working order from steve on here.

Coilpack cant be shafted as its a brand new one, Ht leads are the magnecor ones from k-tec and spark plugs ar Nkg ones,



I phoned renault just to see if they could virginised the Ecu, and they said no because their not allowed as their a main dealer, was worth a try, now their phoning me back around 3 with news, just hope theve done it.
 
  Astra 1.9Cdti SRi
Update:

Phoned renault to see what was happening and not good news.

First off he went on to say that they had nothing coming up when the plugged it into the diagnostics, He then went on to say that it looks like there might be some wires missing off the loom which is utter False, as iv checked the loom before i fitted it and everything was there.

Now they are going to try once more tommorow to try and solve it, but he said were not goin to spend alot of time onit as it will be expensive £77 a hour..

The thing that bugs me is why the heck did nothin come up on the diagnostics, surely it would flag something up, i kno the airbags aint connected so that should have come up atleast.

so now iv orderd the emulator, so just need to contact Paul at Rstuning now to get the ecu virginised.
 
  Meg'd r27
That's weird mate, don't know of anyone that had similar problems putting their conversion in. Hopefully this emulator sorts it for you
 
  Astra 1.9Cdti SRi
Aye its fustrating man, i was in work today and 3pm time came i was nervous as f**k, just wanted them to say yep weve got it up and running, but i was pissed off when they said weve only spent a hour o so onit so your bill is not alot ..

It shouldnt make a different if the engine didnt come from the same car tho, as it should automaticly just connect and fire up..

emailed Paul at rstuning hopefully i can send the Ecu to him tommorow.
 
  Astra 1.9Cdti SRi
Recieved by Ecu back from Rstuning on thursday so had to go buy a solderin iron to fit the emulator, done that pin 28 58 and 3 done as what jord told me to do and.... Nothing.

This time it doesnt turn over atall, iv been to disconnect the battery like 3-4 times, and connect and leaving it but nothing happens
 
take a pic of the inside of your ECU and post it in here...

Find pin 58 on your loom for the ECU connector too, and cut the wire...this way nothing can interfere.

So the starter isnt even cranking?
 
  Astra 1.9Cdti SRi
ok give me a min then so i can go fetch it..

Nope its not cranking over, though it could be my battery as it was dead but iv charged it for a good few hours.
 
  Astra 1.9Cdti SRi
right here is the pic, now my soldering skills is s**t, but iv got them connected tho..

pin 3 black
pin 28 red
pin 58 yellow,

2ee3e175.jpg
 
Pin 58 (yellow on yours, middle row 3rd in from the right) is correct.

The other two are on the wrong pins...they should be like:

DSC03313.jpg


Its the bottom row as you have it opened up, not the top...

But this wouldnt affect the starter motor as it should still crank over
 
  Astra 1.9Cdti SRi
Lmao, how stupid can i be aye,

What i did was open the ecu up and theres a number stamped on top ye, so i took it from that it was left to right so 1-30 across then etc,

il go re-do it now,

back in a jiffy
 
  Astra 1.9Cdti SRi
The immob light still flashes mad even tho iv fitted this emulator to the ecu, is that suppose to happen ?

Tried to turn over and nothing, think it could be my battery this time round tho,
 
Have you snapped off pin 58 on the ECU to loom connector?

Or you can cut the wire that goes from pin 58 to the UCH.

Done either of those too Jay?

Either snap pin 58 off externally or cut the wire....



Then once youve done that carry on. Does the starter solenoid fire or not?
 
  Astra 1.9Cdti SRi
Ye pin 58 has been removed,

Starter doesnt fire atall, it was before i sent ecu to getdone tho,

tried again now, and nothin
 
Starter motor has nothing to do with anything relating to the ECU...

Give the starter/solenoid a tap with a bar/hammer just to see if the solenoid is stuck, because that has to fire and only then will the motor turn over.

If its still no go after that it has to be a dud battery or dodgy battery/earth connection...
 


Top