ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Chris's 172 Cup Turbo



  172 Cup & Mini C 1.6
Just get an old banger mate. I commute 120 miles a day and the 1.2 clio has done me well even though it's hanging a bit now

Sent from my SM-G950F using Tapatalk
 

Iain C

ClioSport Club Member
Car looks great still fella. Prefer the speedlines to the other wheels tbh.
Drop me a pm if your meeting up next if you like. I'm working 6 days a week in uckfield at the moment. I can take the cup to work one Saturday.
 

cjgower

ClioSport Club Member
Car looks great still fella. Prefer the speedlines to the other wheels tbh.
Drop me a pm if your meeting up next if you like. I'm working 6 days a week in uckfield at the moment. I can take the cup to work one Saturday.
Same here mate, I think the 2118's look better too now tbh. I'll let you know when the next meet is on mate don't worry!
 

cjgower

ClioSport Club Member
Bit of an update... the car had been over fuelling for some time and running like a bit of a dog. It only made 215bhp on a recent RR day. Couldn't find the problem myself so booked it in with Engine Dynamics for the week. After chucking the car on the dyno to see what's up and trying a few things they were puzzled as to why the car was running so rich. The last thing they checked was the AEM piggy back ECU.

As it turns out it was that. The first they've had go wrong in this way apparently. The map sensor was faulty and not reading correctly causing a fuelling issue. Sadly it was out of warranty. A kick to the wallet but they replaced it with a new unit, uploaded my original map from 2015 and now it's pulling as well as day one. Happy days :grinning:
 

hsustyle

ClioSport Club Member
  Ph2 flamer 172
Bit of an update... the car had been over fuelling for some time and running like a bit of a dog. It only made 215bhp on a recent RR day. Couldn't find the problem myself so booked it in with Engine Dynamics for the week. After chucking the car on the dyno to see what's up and trying a few things they were puzzled as to why the car was running so rich. The last thing they checked was the AEM piggy back ECU.

As it turns out it was that. The first they've had go wrong in this way apparently. The map sensor was faulty and not reading correctly causing a fuelling issue. Sadly it was out of warranty. A kick to the wallet but they replaced it with a new unit, uploaded my original map from 2015 and now it's pulling as well as day one. Happy days :grinning:
Great News Chris!
 

cjgower

ClioSport Club Member

Mbeau

ClioSport Club Member
  Clio 172
From my knowledge the Cup has different wishbones, but the actual subframe is the same. I have a Cup subframe complete for sale if it helps @cjgower
 

scotiamr2t

ClioSport Club Member
  Mazda 2, Ph1 172
Cup subframe is different to a Ph1 subframe i know that for sure. The mounting holes for the lower arms are located 5mm more outward on the cup subframe
 

cjgower

ClioSport Club Member
Thanks to @Mbeau for the Cup subframe. Collected Thursday, fitted today. The swap was painless enough (although as you can see it wasn't me doing most of the work.) Glad to have had a ramp to work off of!
It's now got powerflexed wishbone and anti roll bar bushes as a bonus. Car isn't in a great way at the moment and looks a little tatty. Moving out this year so it will have to do for now. Plans eventually for a full respray. On the upside, it's just hit 120k and mechanically speaking it's perfect.

New subframe painted up!

The damaged subframe.

Getting worked on:


The damage caused from another run in with black ice and a bush.

Tracking done again and back on the road. Hopefully we've seen the worst of the weather for now. Can't lie, as fun as it is driving this as a daily it's just not cut out for it and neither is my bank balance or my ears. Must be getting old. Will hopefully get a second car soon.
 

cjgower

ClioSport Club Member
How much does it realistially cost to run over a week?
From the top of my head not including things like tyres, servicing etc but including tax, fuel and insurance it’s working out at roughly £360 a month. The majority of which is fuel. That’s probably small change to some of the ballers on here but not to me lol
 

Dr Jekyll

ClioSport Club Member
I do insurance and tax in one hit so I wasnt thinking of those. I was just trying to get an idea on how much fuel it costs during your week over your miles.

I think I do £30ish a week doing 200 miles approx. Just wandered what a boasted one in daily use would cost as a comparison.
 
  172 Cup & Mini C 1.6
Mate get yourself a cheap old banger. Said this ages ago to you it's so worth it. Glad it's on the mend mate it's a lovely cup. On the plus side I look forward to a catch up this weekend

Sent from my SM-G950F using Tapatalk
 
  Ftype SVR & E46 M3
HI there

Stunning car, do you still prefer the grams over the pro lines and cooksports handling wise on the road?
 

cjgower

ClioSport Club Member
I haven't been on here in sooo long. Where do I start.

The boosted Cup is no more. A slight mishap on a corner saw to that. We'll leave it at that. The good news is that I'm building another boosted cup using the old parts.

Anyone able to advise on oil coolers. Should I get an 82 degree thermostatic sandwich plate or a 92? the car will be driven on the road. Will barely see a track.

Here is the new Cup ?

734F9017-46CE-45D7-94F2-58EECBD26C07.jpg
 

cjgower

ClioSport Club Member
Updates on the car as it is at the moment - boost is back! here's a little step by step of it all coming together again in the new shell. I've learn't a heck of a lot doing the majority of this work myself although I did have help with the wiring back in etc.

Still to do are brembos back on, full suspension refresh, arches fixed due to rust and general tidy up of car inside out etc.

Engine out of old car. Was actually fair easy - most time consuming was labelling wires for injectors etc where they had been spliced into standard loom.

IMG_8566.JPG


Engine out, ready for new genuine belts, oil change etc before going back in new shell.

IMG_8571.JPG


Engine removed from other car, the cleaning could commence! took ages doing this, cleaning it up, painting it with some left over paint from a spray shop to match colour of the car. Didn't grab so many of the before and after sorry!

IMG_9773 2.JPG


Engine back from having belts done, decided to paint it with some VHT. Not the best job in the world as most of the components bar alternator stayed on, but certainly an improvement on before.

IMG_9899 2.JPG


Engine back in: Notice all the coolant pipes etc chucked on top. Had enough at this point so decided to call it a day and go get beer.

IMG_9954 2.JPG


Finishing touches. Painted the intercooler black which is cool as it's now hidden from sight.

IMG_0172.JPG


Back together again. Drives brilliantly, a few issues to sort but fairly certain that can be said for most 1*2's these days. Cheers for looking

P1140054.JPG
 

cjgower

ClioSport Club Member
Rather than create a new thread, just thought I would ask on here. Have tried to search but have no luck.

Fitted a new alternator but the battery keeps running flat, suggesting that it’s
actually the battery that’s had it or there is a power drain somewhere. What’s the best way of ruling one or the other out?
 

Louis

ClioSport Club Member
Rather than create a new thread, just thought I would ask on here. Have tried to search but have no luck.

Fitted a new alternator but the battery keeps running flat, suggesting that it’s
actually the battery that’s had it or there is a power drain somewhere. What’s the best way of ruling one or the other out?
Pop a multimeter on it to see if battery. If not, check pull on the battery with the multimeter and remove fuses until it goes away.
 

robmuns

ClioSport Club Member
  Ph1 172
Rather than create a new thread, just thought I would ask on here. Have tried to search but have no luck.

Fitted a new alternator but the battery keeps running flat, suggesting that it’s
actually the battery that’s had it or there is a power drain somewhere. What’s the best way of ruling one or the other out?
Check the gearbox earth strap to the chassis
 

cjgower

ClioSport Club Member
Little update on the car at the moment. Recently gave it some fresh oil to mark almost a year since this car has had the old engine fitted. During that time it’s had a new alternator and starter motor.

The 2118’s have gone to free up cash for some improvements, the first being fresh Cup shocks and a complete brake overhaul.

I’ve also started tidying up under the arches by cleaning and sealing with hammerite underseal in an effort to protect the car as much as possible.

Fitted a fresh set of studs in preparation for the brembos to go back on, along with MTEC discs and new Brembo pads waiting to go on once the brakes have been refurbed. They will be silver this time around as opposed to yellow. The aim is to make the car as OEM as possible moving forward, aesthetically at least.

2783D117-4C6B-4601-A730-0BCFAA199493.jpeg


A2FEC259-DC28-4306-94C6-59C7FDE7A1FE.jpeg


F7C05776-E1D2-4F50-B21A-5A7AF7F57A66.jpeg


I’ll make sure to get some better before and afters of the other side.
 

Louis

ClioSport Club Member
Little update on the car at the moment. Recently gave it some fresh oil to mark almost a year since this car has had the old engine fitted. During that time it’s had a new alternator and starter motor.

The 2118’s have gone to free up cash for some improvements, the first being fresh Cup shocks and a complete brake overhaul.

I’ve also started tidying up under the arches by cleaning and sealing with hammerite underseal in an effort to protect the car as much as possible.

Fitted a fresh set of studs in preparation for the brembos to go back on, along with MTEC discs and new Brembo pads waiting to go on once the brakes have been refurbed. They will be silver this time around as opposed to yellow. The aim is to make the car as OEM as possible moving forward, aesthetically at least.

View attachment 1433214

View attachment 1433211

View attachment 1433212

I’ll make sure to get some better before and afters of the other side.
Looks great but pleeeeease move the axle stand under the car. The front sills crumple for fun
 

cjgower

ClioSport Club Member
September has been a good month for the Cup.

- Complete Cup Suspension refresh
- Brembo’s refurbished and back on car
- MTEC drilled and grooved discs + Brembo pads
- Stud conversion with 10mm PMS spacers
- New Cup alternator from RPD

Also found the source of the power drain. EPAS conversion. Looks like the gearbox earth strap was ok, but other earths near to the passengers side headlight were heavily corroded so gave them a clean too.

The car no has no power steering, but starts without the need to jump start and is reading 14v at the battery which is good. Will look at why the EPAS is causing the drain another time.

Brembos / suspension complete. Booked in for the rust to be sorted on the 8th of next month. Excited!. I’ll get before and afters of the work.

7C95EB0B-39D9-48F2-AB7A-142E71C7FEE9.jpeg


10mm makes a big difference. Still have rears to fit.
648E261C-B9A6-4B61-8BBB-BC3C5897499F.jpeg
 

cjgower

ClioSport Club Member
Not the most exciting of updates, but car goes in tomorrow for rust repair.

Spent the weekend getting the car ready, removing rear door cards, side skirts etc. Also fitted rear 10mm spacers - loving the way the car sits now.

0C1A7E5C-8455-48F5-B714-89C4BEE0033B.jpeg


Hoping the sills haven’t gone completely but we will see. Either way it’s getting sorted which is what matters.

AEC4B9D9-DB03-4CF0-8B7F-C8758826045C.jpeg


F9210E03-82C6-4F07-AE10-8BEEFDF71B5D.jpeg


518A4B41-9F0A-459E-9A97-71ACC10DAFA8.jpeg


Shot from below looking straight up at the ‘sill’ on the passenger side.
17FEA406-7B0B-4CD7-9BA7-8F43E3FB8E9A.jpeg


D6369FDC-E65A-4196-988A-349DCC44D197.jpeg


6A7CFD3C-BBB6-400A-B3C0-5423882BD58C.jpeg


Next up will be rainsport 3’s going on and MOT time which it will sail through...
 
Last edited:

cjgower

ClioSport Club Member
Pictures of the progress so far. Bit of a weird one, but anyone had issues with the doors and rear quarter not matching well after spraying?

Rather than being an issue with the colour, is this just 16 year old never been machine polished paint vs brand new paint?

Overall really happy with the finish and quality of the work carried out. Will update with some pretty pictures of sills etc next week. Talk of carrying on this colour through the doors as it seems to match the rest of the car, just not the doors.
 

Attachments

GrahamS

ClioSport Club Member
They should match well if the shade is well matched, spray out cards are used and it’s blended into the next panel. Often shops don’t mix their own paint and order without checking the shade. Had it a couple of times sadly. New vs old paint is sometimes very obvious though so a machine polish on the older panel is a good idea. As both panels are metal I would expect them to have a perfect match. Plastic to metal is different and does often have slight differences.
 


Top