ClioSport.net

Register a free account today to become a member!
Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Whiteline ARB fitting problem?



David172

ClioSport Club Member
  Clio 172 M135i
Hi all,

Currently trying to fit a new rear ARB and I have a slight probelm 😬

Doing up the nylock nuts on the links is stupidly difficult. Im having to use a breaker bar to get the nut to turn. In the process the link has been bent out of shape! See pic..

Should they be this bloody tight and if so any tips on not bending the f ing links in the process?

Thanks
 

Attachments

  • 20190928_131603.jpg
    20190928_131603.jpg
    249.6 KB · Views: 87

Daz...

ClioSport Club Member
  Inferno 182 Cup
They shouldn’t be that tight.

Mine was second hand and I’ve never had a problem with those nuts.

Sounds like the nut has cross threaded as it’s gone on.
 

David172

ClioSport Club Member
  Clio 172 M135i
Ah jeez I hope it hasn't but you could be right! I think ill undo it and see if there is any damage.
 

David172

ClioSport Club Member
  Clio 172 M135i
This is the same nut (for the other side). Only had it on 2 turns and the threads look slightly stripped :/
 

Attachments

  • 20190928_134715.jpg
    20190928_134715.jpg
    374.3 KB · Views: 46

Louis

ClioSport Club Member
Are you sure you're using the correct nuts? They're imperial on the u bolts but not sure on the rose joints.
Definitely cutting into the nyloc thread and you dont want to be forcing them on.
 

David172

ClioSport Club Member
  Clio 172 M135i
Ive just read an old thread about this ARB and I think I might have used the wrong nuts so yeah I think you are right. s**t lol. Ok ill see if I can sort this. Thanks :ROFLMAO:
 

David172

ClioSport Club Member
  Clio 172 M135i
Yeah the embarrassing thing is ive been following those instructions! I think ive got lucky though as the link has bent back into shape from removing the nut and the threads are fine.

Thanks for your help!

Moral of the story - get to know your nuts first.
 

David172

ClioSport Club Member
  Clio 172 M135i
Yeah I did look at the washers and think it was strange putting them that way, after the nut issue though I didn't want to ignoor the instructions :LOL:
 


Top